bind9.16-debuginfo vulnerabilities (Red Hat)
35 vulnerabilities.
-
bind9.16-debuginfoRed Hat Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind9.16-debuginfoRed Hat Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind9.16-debuginfoRed Hat Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind9.16-debuginfoRed Hat DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind9.16-debuginfoRed Hat Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind9.16-debuginfoRed Hat Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bind9.16-debuginfoRed Hat Potential memory usage beyond configured limits 7.5 High -
bind9.16-debuginfoRed Hat Potential wildcard CNAME RPZ policy bypass 7.5 High -
bind9.16-debuginfoRed Hat Incorrect acceptance of NSEC3 records 6.8 Medium -
bind9.16-debuginfoRed Hat Invalid handling of CLASS != IN 7.5 High -
bind9.16-debuginfoRed Hat BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind9.16-debuginfoRed Hat Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind9.16-debuginfoRed Hat Cache poisoning due to weak PRNG 8.6 High -
bind9.16-debuginfoRed Hat Cache poisoning attacks with unsolicited RRs 8.6 High -
bind9.16-debuginfoRed Hat Many records in the additional section cause CPU exhaustion 7.5 High -
bind9.16-debuginfoRed Hat Assertion failure when serving both stale cache data and authoritative zone content 7.5 High -
bind9.16-debuginfoRed Hat SIG(0) can be used to exhaust CPU resources 7.5 High -
bind9.16-debuginfoRed Hat BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind9.16-debuginfoRed Hat Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bind9.16-debuginfoRed Hat Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution 7.5 High -
bind9.16-debuginfoRed Hat Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled 7.5 High -
bind9.16-debuginfoRed Hat The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind9.16-debuginfoRed Hat Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind9.16-debuginfoRed Hat Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind9.16-debuginfoRed Hat A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind9.16-debuginfoRed Hat named's configured cache size limit can be significantly exceeded 7.5 High -
bind9.16-debuginfoRed Hat named configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quota 7.5 High -
bind9.16-debuginfoRed Hat named configured to answer from stale cache may terminate unexpectedly while processing RRSIG queries 7.5 High -
bind9.16-debuginfoRed Hat An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind9.16-debuginfoRed Hat Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind9.16-debuginfoRed Hat Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind9.16-debuginfoRed Hat BIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate unexpectedly 7.5 High -
bind9.16-debuginfoRed Hat Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind9.16-debuginfoRed Hat DoS from specifically crafted TCP packets 5.3 Medium -
bind9.16-debuginfoRed Hat DNS forwarders - cache poisoning vulnerability 6.8 Medium