python3-bind vulnerabilities (Red Hat)
51 vulnerabilities.
-
python3-bindRed Hat Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
python3-bindRed Hat Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
python3-bindRed Hat Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
python3-bindRed Hat DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
python3-bindRed Hat Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
python3-bindRed Hat Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
python3-bindRed Hat Potential memory usage beyond configured limits 7.5 High -
python3-bindRed Hat Potential wildcard CNAME RPZ policy bypass 7.5 High -
python3-bindRed Hat Incorrect acceptance of NSEC3 records 6.8 Medium -
python3-bindRed Hat Invalid handling of CLASS != IN 7.5 High -
python3-bindRed Hat BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
python3-bindRed Hat Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
python3-bindRed Hat Resource exhaustion via malformed DNSKEY handling 7.5 High -
python3-bindRed Hat Cache poisoning due to weak PRNG 8.6 High -
python3-bindRed Hat Cache poisoning attacks with unsolicited RRs 8.6 High -
python3-bindRed Hat Many records in the additional section cause CPU exhaustion 7.5 High -
python3-bindRed Hat Assertion failure when serving both stale cache data and authoritative zone content 7.5 High -
python3-bindRed Hat SIG(0) can be used to exhaust CPU resources 7.5 High -
python3-bindRed Hat BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
python3-bindRed Hat Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
python3-bindRed Hat Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution 7.5 High -
python3-bindRed Hat Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled 7.5 High -
python3-bindRed Hat The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
python3-bindRed Hat Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
python3-bindRed Hat Parsing large DNS messages may cause excessive CPU load 7.5 High -
python3-bindRed Hat A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
python3-bindRed Hat named's configured cache size limit can be significantly exceeded 7.5 High -
python3-bindRed Hat named configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quota 7.5 High -
python3-bindRed Hat named configured to answer from stale cache may terminate unexpectedly while processing RRSIG queries 7.5 High -
python3-bindRed Hat An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
python3-bindRed Hat Memory leaks in EdDSA DNSSEC verification code 7.5 High -
python3-bindRed Hat Memory leak in ECDSA DNSSEC verification code 7.5 High -
python3-bindRed Hat BIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate unexpectedly 7.5 High -
python3-bindRed Hat Processing large delegations may severely degrade resolver performance 5.3 Medium -
python3-bindRed Hat DoS from specifically crafted TCP packets 5.3 Medium -
python3-bindRed Hat DNS forwarders - cache poisoning vulnerability 6.8 Medium -
python3-bindRed Hat Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
python3-bindRed Hat An assertion check can fail while answering queries for DNAME records that require the DNAME to be processed to resolve itself 7.5 High -
python3-bindRed Hat A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium -
python3-bindRed Hat A vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack 8.1 High -
python3-bindRed Hat update-policy rules of type "subdomain" are enforced incorrectly 4.3 Medium -
python3-bindRed Hat A flaw in native PKCS#11 code can lead to a remotely triggerable assertion failure in pk11.c 7.5 High -
python3-bindRed Hat A truncated TSIG response can lead to an assertion failure 6.5 Medium -
python3-bindRed Hat A buffer boundary check assertion in rdataset.c can fail incorrectly during zone transfer 4.9 Medium -
python3-bindRed Hat A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c 7.5 High -
python3-bindRed Hat BIND does not sufficiently limit the number of fetches performed when processing referrals 8.6 High -
python3-bindRed Hat TCP-pipelined queries can bypass tcp-clients limit 7.5 High -
python3-bindRed Hat A race condition when discarding malformed packets can cause BIND to exit with an assertion failure 5.9 Medium -
python3-bindRed Hat Limiting simultaneous TCP clients was ineffective 7.5 High -
python3-bindRed Hat Zone transfer controls for writable DLZ zones were not effective 5.3 Medium - Show olderLoading…