bind vulnerabilities (Rocky Linux)
42 vulnerabilities.
-
bindRocky Linux Specific RPZ configurations and query patterns may result in an unexpected exit 7.5 High -
bindRocky Linux Named may terminate unexpectedly when a redirect zone is used with strict QNAME minimization 7.5 High -
bindRocky Linux Concurrent GSS-TSIG messages corrupt memory 8.1 High -
bindRocky Linux Amplified resource exhaustion in inbound message processing 7.5 High -
bindRocky Linux Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bindRocky Linux Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bindRocky Linux SVCB AliasMode additional-data error leaks qpcache references 7.5 High -
bindRocky Linux qpcache NOQNAME proof use-after-free crashes recursive resolver 5.9 Medium -
bindRocky Linux Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bindRocky Linux Remote CPU denial of service through cached SVCB/HTTPS AliasMode trees 7.5 High -
bindRocky Linux DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bindRocky Linux Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bindRocky Linux Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bindRocky Linux Potential memory usage beyond configured limits 7.5 High -
bindRocky Linux Potential wildcard CNAME RPZ policy bypass 7.5 High -
bindRocky Linux Incorrect acceptance of NSEC3 records 6.8 Medium -
bindRocky Linux Invalid handling of CLASS != IN 7.5 High -
bindRocky Linux BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bindRocky Linux Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bindRocky Linux Resource exhaustion via malformed DNSKEY handling 7.5 High -
bindRocky Linux Cache poisoning due to weak PRNG 8.6 High -
bindRocky Linux Cache poisoning attacks with unsolicited RRs 8.6 High -
bindRocky Linux Many records in the additional section cause CPU exhaustion 7.5 High -
bindRocky Linux Assertion failure when serving both stale cache data and authoritative zone content 7.5 High -
bindRocky Linux SIG(0) can be used to exhaust CPU resources 7.5 High -
bindRocky Linux BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bindRocky Linux Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bindRocky Linux Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution 7.5 High -
bindRocky Linux Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled 7.5 High -
bindRocky Linux The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bindRocky Linux Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bindRocky Linux Parsing large DNS messages may cause excessive CPU load 7.5 High -
bindRocky Linux A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bindRocky Linux named's configured cache size limit can be significantly exceeded 7.5 High -
bindRocky Linux Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bindRocky Linux Memory leak in ECDSA DNSSEC verification code 7.5 High -
bindRocky Linux BIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate unexpectedly 7.5 High -
bindRocky Linux DoS from specifically crafted TCP packets 5.3 Medium -
bindRocky Linux DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bindRocky Linux Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
bindRocky Linux An assertion check can fail while answering queries for DNAME records that require the DNAME to be processed to resolve itself 7.5 High -
bindRocky Linux A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium