bind-sdb vulnerabilities (TuxCare)
33 vulnerabilities.
-
bind-sdbTuxCare Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind-sdbTuxCare Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind-sdbTuxCare Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind-sdbTuxCare DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind-sdbTuxCare Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind-sdbTuxCare Potential memory usage beyond configured limits 7.5 High -
bind-sdbTuxCare Incorrect acceptance of NSEC3 records 6.8 Medium -
bind-sdbTuxCare Invalid handling of CLASS != IN 7.5 High -
bind-sdbTuxCare Amplification vulnerabilities via self-pointed glue records 5.3 Medium -
bind-sdbTuxCare BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind-sdbTuxCare Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind-sdbTuxCare Cache poisoning attacks with unsolicited RRs 8.6 High -
bind-sdbTuxCare Many records in the additional section cause CPU exhaustion 7.5 High -
bind-sdbTuxCare SIG(0) can be used to exhaust CPU resources 7.5 High -
bind-sdbTuxCare BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind-sdbTuxCare Update of bind No score -
bind-sdbTuxCare Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bind-sdbTuxCare The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind-sdbTuxCare Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind-sdbTuxCare Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind-sdbTuxCare A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind-sdbTuxCare named's configured cache size limit can be significantly exceeded 7.5 High -
bind-sdbTuxCare An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind-sdbTuxCare Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind-sdbTuxCare Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind-sdbTuxCare Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind-sdbTuxCare DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bind-sdbTuxCare Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
bind-sdbTuxCare A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack 8.1 High -
bind-sdbTuxCare An assertion check can fail while answering queries for DNAME records that require the DNAME to be processed to resolve itself 7.5 High -
bind-sdbTuxCare A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium -
bind-sdbTuxCare A vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack 8.1 High -
bind-sdbTuxCare Update policies krb5-subdomain and ms-subdomain do not enforce controls promised in their documentation 6.5 Medium