bind-utils vulnerabilities (TuxCare)
49 vulnerabilities.
-
bind-utilsTuxCare NSEC3 insecure-referral proof can use unrelated cached NSEC3 RRsets 5.9 Medium -
bind-utilsTuxCare Message parser retains every identical singleton RDATA, enabling wire-to-work amplification 5.3 Medium -
bind-utilsTuxCare Resource Exhaustion via Excessive DNSSEC Cryptographic Material Matching 5.3 Medium -
bind-utilsTuxCare Unauthenticated IXFR deltas are applied to the live zone before TSIG verification 6.5 Medium -
bind-utilsTuxCare Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind-utilsTuxCare Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind-utilsTuxCare Out-of-zone database nodes can become authoritative zone cuts 5.8 Medium -
bind-utilsTuxCare checkwildcard() accepts an out-of-zone NSEC as a wildcard-nonexistence proof 5.9 Medium -
bind-utilsTuxCare qpcache NOQNAME proof use-after-free crashes recursive resolver 5.9 Medium -
bind-utilsTuxCare Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind-utilsTuxCare DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind-utilsTuxCare Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind-utilsTuxCare Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bind-utilsTuxCare Potential memory usage beyond configured limits 7.5 High -
bind-utilsTuxCare Potential wildcard CNAME RPZ policy bypass 7.5 High -
bind-utilsTuxCare Incorrect acceptance of NSEC3 records 6.8 Medium -
bind-utilsTuxCare Unbounded resend loop in BIND 9 resolver 5.3 Medium -
bind-utilsTuxCare Invalid handling of CLASS != IN 7.5 High -
bind-utilsTuxCare Amplification vulnerabilities via self-pointed glue records 5.3 Medium -
bind-utilsTuxCare BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind-utilsTuxCare Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind-utilsTuxCare Resource exhaustion via malformed DNSKEY handling 7.5 High -
bind-utilsTuxCare Cache poisoning due to weak PRNG 8.6 High -
bind-utilsTuxCare Cache poisoning attacks with unsolicited RRs 8.6 High -
bind-utilsTuxCare Many records in the additional section cause CPU exhaustion 7.5 High -
bind-utilsTuxCare Assertion failure when serving both stale cache data and authoritative zone content 7.5 High -
bind-utilsTuxCare SIG(0) can be used to exhaust CPU resources 7.5 High -
bind-utilsTuxCare BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind-utilsTuxCare Update of bind No score -
bind-utilsTuxCare Update of bind No score -
bind-utilsTuxCare Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bind-utilsTuxCare Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution 7.5 High -
bind-utilsTuxCare Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled 7.5 High -
bind-utilsTuxCare The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind-utilsTuxCare Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind-utilsTuxCare Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind-utilsTuxCare A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind-utilsTuxCare named's configured cache size limit can be significantly exceeded 7.5 High -
bind-utilsTuxCare An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind-utilsTuxCare Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind-utilsTuxCare Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind-utilsTuxCare Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind-utilsTuxCare DNS forwarders - cache poisoning vulnerability 6.8 Medium -
bind-utilsTuxCare Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
bind-utilsTuxCare A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack 8.1 High -
bind-utilsTuxCare An assertion check can fail while answering queries for DNAME records that require the DNAME to be processed to resolve itself 7.5 High -
bind-utilsTuxCare A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium -
bind-utilsTuxCare A vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack 8.1 High -
bind-utilsTuxCare Update policies krb5-subdomain and ms-subdomain do not enforce controls promised in their documentation 6.5 Medium