isc-dhcp vulnerabilities (Ubuntu)
55 vulnerabilities.
-
isc-dhcpUbuntu Specific RPZ configurations and query patterns may result in an unexpected exit 7.5 High -
isc-dhcpUbuntu Named may terminate unexpectedly when a redirect zone is used with strict QNAME minimization 7.5 High -
isc-dhcpUbuntu Concurrent GSS-TSIG messages corrupt memory 8.1 High -
isc-dhcpUbuntu Amplified resource exhaustion in inbound message processing 7.5 High -
isc-dhcpUbuntu NSEC3 insecure-referral proof can use unrelated cached NSEC3 RRsets 5.9 Medium -
isc-dhcpUbuntu Message parser retains every identical singleton RDATA, enabling wire-to-work amplification 5.3 Medium -
isc-dhcpUbuntu Resource Exhaustion via Excessive DNSSEC Cryptographic Material Matching 5.3 Medium -
isc-dhcpUbuntu Unauthenticated IXFR deltas are applied to the live zone before TSIG verification 6.5 Medium -
isc-dhcpUbuntu Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
isc-dhcpUbuntu named aborts on a TKEY query when the user configuration has no global options statement 7.5 High -
isc-dhcpUbuntu Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
isc-dhcpUbuntu SVCB AliasMode additional-data error leaks qpcache references 7.5 High -
isc-dhcpUbuntu Out-of-zone database nodes can become authoritative zone cuts 5.8 Medium -
isc-dhcpUbuntu Unauthenticated remote crash of named via a single DoH SIG(0) request 7.5 High -
isc-dhcpUbuntu checkwildcard() accepts an out-of-zone NSEC as a wildcard-nonexistence proof 5.9 Medium -
isc-dhcpUbuntu qpcache NOQNAME proof use-after-free crashes recursive resolver 5.9 Medium -
isc-dhcpUbuntu Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
isc-dhcpUbuntu Remote CPU denial of service through cached SVCB/HTTPS AliasMode trees 7.5 High -
isc-dhcpUbuntu Dhcp-server: dhcp-server: persistent denial of service due to buffer overflow via omapi 4.9 Medium -
isc-dhcpUbuntu DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
isc-dhcpUbuntu Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
isc-dhcpUbuntu Record ordering based unexpected exit with CNAME or DNAME 7.5 High -
isc-dhcpUbuntu Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
isc-dhcpUbuntu Potential memory usage beyond configured limits 7.5 High -
isc-dhcpUbuntu Potential wildcard CNAME RPZ policy bypass 7.5 High -
isc-dhcpUbuntu Key Record using PRIVATEDNS algorithm may lead to unexpected exit 6.5 Medium -
isc-dhcpUbuntu Incorrect acceptance of NSEC3 records 6.8 Medium -
isc-dhcpUbuntu Unbounded resend loop in BIND 9 resolver 5.3 Medium -
isc-dhcpUbuntu Amplification vulnerabilities via self-pointed glue records 5.3 Medium -
isc-dhcpUbuntu A stack use-after-return flaw in SIG(0) handling code may enable ACL bypass 5.4 Medium -
isc-dhcpUbuntu Authenticated query containing a TKEY record may cause named to terminate unexpectedly 6.5 Medium -
isc-dhcpUbuntu Memory leak in code preparing DNSSEC proofs of non-existence 7.5 High -
isc-dhcpUbuntu Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
isc-dhcpUbuntu Resource exhaustion via malformed DNSKEY handling 7.5 High -
isc-dhcpUbuntu Cache poisoning due to weak PRNG 8.6 High -
isc-dhcpUbuntu Cache poisoning attacks with unsolicited RRs 8.6 High -
isc-dhcpUbuntu DNS-over-HTTPS implementation suffers from multiple issues under heavy query load 7.5 High -
isc-dhcpUbuntu Many records in the additional section cause CPU exhaustion 7.5 High -
isc-dhcpUbuntu SIG(0) can be used to exhaust CPU resources 7.5 High -
isc-dhcpUbuntu BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
isc-dhcpUbuntu A flood of DNS messages over TCP may make the server unstable 7.5 High -
isc-dhcpUbuntu The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
isc-dhcpUbuntu Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
isc-dhcpUbuntu Parsing large DNS messages may cause excessive CPU load 7.5 High -
isc-dhcpUbuntu named's configured cache size limit can be significantly exceeded 7.5 High -
isc-dhcpUbuntu DHCP memory leak 6.5 Medium -
isc-dhcpUbuntu An option refcount overflow exists in dhcpd 6.5 Medium -
isc-dhcpUbuntu Processing large delegations may severely degrade resolver performance 5.3 Medium -
isc-dhcpUbuntu A buffer overrun in lease file parsing code can be used to exploit a common vulnerability shared by dhcpd and dhclient 7.4 High -
isc-dhcpUbuntu dhcpd: use-after-free error leads crash in IPv6 mode when using mismatched BIND libraries 6.5 Medium - Show olderLoading…