bind vulnerabilities (openEuler)
55 vulnerabilities.
-
bindopenEuler NSEC3 insecure-referral proof can use unrelated cached NSEC3 RRsets 5.9 Medium -
bindopenEuler Message parser retains every identical singleton RDATA, enabling wire-to-work amplification 5.3 Medium -
bindopenEuler Resource Exhaustion via Excessive DNSSEC Cryptographic Material Matching 5.3 Medium -
bindopenEuler Unauthenticated IXFR deltas are applied to the live zone before TSIG verification 6.5 Medium -
bindopenEuler Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bindopenEuler SVCB AliasMode additional-data error leaks qpcache references 7.5 High -
bindopenEuler Out-of-zone database nodes can become authoritative zone cuts 5.8 Medium -
bindopenEuler checkwildcard() accepts an out-of-zone NSEC as a wildcard-nonexistence proof 5.9 Medium -
bindopenEuler qpcache NOQNAME proof use-after-free crashes recursive resolver 5.9 Medium -
bindopenEuler Remote CPU denial of service through cached SVCB/HTTPS AliasMode trees 7.5 High -
bindopenEuler DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bindopenEuler Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bindopenEuler Record ordering based unexpected exit with CNAME or DNAME 7.5 High -
bindopenEuler Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bindopenEuler Potential memory usage beyond configured limits 7.5 High -
bindopenEuler Unnecessary validation of DNSSEC signed records 7.5 High -
bindopenEuler Potential wildcard CNAME RPZ policy bypass 7.5 High -
bindopenEuler Key Record using PRIVATEDNS algorithm may lead to unexpected exit 6.5 Medium -
bindopenEuler Incorrect acceptance of NSEC3 records 6.8 Medium -
bindopenEuler Invalid handling of CLASS != IN 7.5 High -
bindopenEuler Amplification vulnerabilities via self-pointed glue records 5.3 Medium -
bindopenEuler BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bindopenEuler Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bindopenEuler Resource exhaustion via malformed DNSKEY handling 7.5 High -
bindopenEuler Cache poisoning due to weak PRNG 8.6 High -
bindopenEuler Cache poisoning attacks with unsolicited RRs 8.6 High -
bindopenEuler DNS-over-HTTPS implementation suffers from multiple issues under heavy query load 7.5 High -
bindopenEuler Many records in the additional section cause CPU exhaustion 7.5 High -
bindopenEuler Assertion failure when serving both stale cache data and authoritative zone content 7.5 High -
bindopenEuler SIG(0) can be used to exhaust CPU resources 7.5 High -
bindopenEuler BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bindopenEuler A flood of DNS messages over TCP may make the server unstable 7.5 High -
bindopenEuler Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bindopenEuler Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution 7.5 High -
bindopenEuler Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled 7.5 High -
bindopenEuler The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bindopenEuler Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bindopenEuler Parsing large DNS messages may cause excessive CPU load 7.5 High -
bindopenEuler A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bindopenEuler named's configured cache size limit can be significantly exceeded 7.5 High -
bindopenEuler named configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quota 7.5 High -
bindopenEuler named configured to answer from stale cache may terminate unexpectedly while processing RRSIG queries 7.5 High -
bindopenEuler An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bindopenEuler Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bindopenEuler Memory leak in ECDSA DNSSEC verification code 7.5 High -
bindopenEuler BIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate unexpectedly 7.5 High -
bindopenEuler Memory leaks in code handling Diffie-Hellman key exchange via TKEY RRs (OpenSSL 3.0.0+ only) 7.5 High -
bindopenEuler Buffer overread in statistics channel code 5.5 Medium -
bindopenEuler Processing large delegations may severely degrade resolver performance 5.3 Medium -
bindopenEuler DoS from specifically crafted TCP packets 5.3 Medium - Show olderLoading…