pdns-recursor vulnerabilities (openSUSE)
31 vulnerabilities.
-
pdns-recursoropenSUSE A Recursor configured to send out ECS enabled queries can be sensitive to spoofing attempts 7.5 High -
pdns-recursoropenSUSE Crafted responses can lead to a denial of service due to cache inefficiencies in the Recursor 7.5 High -
pdns-recursoropenSUSE Crafted responses can lead to a denial of service in Recursor if recursive forwarding is configured 7.5 High -
pdns-recursoropenSUSE The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
pdns-recursoropenSUSE Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
pdns-recursoropenSUSE Deterred spoofing attempts can lead to authoritative servers being marked unavailable 3.4 Low -
pdns-recursoropenSUSE A remote attacker might be able to cause infinite recursion in PowerDNS Recursor 4.8.0 via a DNS... 7.5 High -
pdns-recursoropenSUSE PowerDNS Recursor up to and including 4.5.9, 4.6.2 and 4.7.1, when protobuf logging is enabled,... 6.5 Medium -
pdns-recursoropenSUSE In PowerDNS Authoritative Server before 4.4.3, 4.5.x before 4.5.4, and 4.6.x before 4.6.1 and... 7.5 High -
pdns-recursoropenSUSE An issue has been found in PowerDNS Recursor before 4.1.18, 4.2.x before 4.2.5, and 4.3.x before... 7.5 High -
pdns-recursoropenSUSE In PowerDNS Recursor versions up to and including 4.3.1, 4.2.2 and 4.1.16, the ACL restricting... 5.3 Medium -
pdns-recursoropenSUSE An issue has been found in PowerDNS Recursor 4.1.0 through 4.3.0 where records in the answer... 7.5 High -
pdns-recursoropenSUSE PowerDNS Recursor from 4.1.0 up to and including 4.3.0 does not sufficiently defend against... 7.5 High -
pdns-recursoropenSUSE An issue has been found in PowerDNS Recursor 4.1.0 up to and including 4.3.0. It allows an... 8.8 High -
pdns-recursoropenSUSE An issue has been found in PowerDNS Recursor versions 4.1.x before 4.1.9 where records in the... 3.7 Low -
pdns-recursoropenSUSE An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks... 5.4 Medium -
pdns-recursoropenSUSE An issue has been found in PowerDNS Recursor before version 4.1.8 where a remote attacker sending... 7.5 High -
pdns-recursoropenSUSE PowerDNS Authoritative Server 4.1.0 up to 4.1.4 inclusive and PowerDNS Recursor 4.0.0 up to 4.1.4... 5.3 Medium -
pdns-recursoropenSUSE PowerDNS Authoritative Server 3.3.0 up to 4.1.4 excluding 4.1.5 and 4.0.6, and PowerDNS Recursor... 5.3 Medium -
pdns-recursoropenSUSE An issue has been found in PowerDNS Recursor from 4.0.0 up to and including 4.1.4. A remote... 5.3 Medium -
pdns-recursoropenSUSE An issue has been found in the DNSSEC parsing code of PowerDNS Recursor from 4.0.0 up to and... 5.9 Medium -
pdns-recursoropenSUSE When api-config-dir is set to a non-empty value, which is not the case by default, the API in... 5.3 Medium -
pdns-recursoropenSUSE A cross-site scripting issue has been found in the web interface of PowerDNS Recursor from 4.0.0... 6.1 Medium -
pdns-recursoropenSUSE An issue has been found in the DNSSEC validation component of PowerDNS Recursor from 4.0.0 and up... 5.9 Medium -
pdns-recursoropenSUSE Improper input validation bugs in DNSSEC validators components in PowerDNS version 4.1.0 allow... 3.7 Low -
pdns-recursoropenSUSE An issue has been found in PowerDNS before 3.4.11 and 4.0.2, and PowerDNS recursor before 3.7.4... 5.3 Medium -
pdns-recursoropenSUSE An issue has been found in PowerDNS Authoritative Server versions up to and including 3.4.10, 4.0... 7.5 High -
pdns-recursoropenSUSE PowerDNS (aka pdns) Authoritative Server before 4.0.1 allows remote primary DNS servers to cause... 6.8 Medium -
pdns-recursoropenSUSE The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and 3.7.x... 7.8 High -
pdns-recursoropenSUSE PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote attackers... 5.0 Medium -
pdns-recursoropenSUSE Buffer overflow in PowerDNS Recursor before 3.1.7.2 allows remote attackers to cause a denial of... 10.0 High