CVE-2017-1000501
Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the ...
Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.
- Record
CVE-2017-1000501- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.
- Record
CVE-2017-1000501- Updated
- 2026-11-02
EUVDEUVD-2017-1610 No score
Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.
- Record
EUVD-2017-1610- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-ph65-4f3r-7fv8
9.8
Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the ...
Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.
- Record
GHSA-ph65-4f3r-7fv8- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVALPINE-CVE-2017-1000501
9.8
Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.
- Record
ALPINE-CVE-2017-1000501- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
9.8
Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.
- Record
CVE-2017-1000501- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2017-1000501
9.8
Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.
- Record
DEBIAN-CVE-2017-1000501- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-1000501
9.8
Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.
- Record
UBUNTU-CVE-2017-1000501- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0045 No score
Updated awstats packages fix security vulnerability
The cPanel Security Team discovered two path traversal flaws in awstats in the "config" and "migrate" parameters that could be leveraged for unauthenticated remote code execution (CVE-2017-1000501).
- Record
MGASA-2018-0045- Updated
- 2026-11-02
OSVUSN-3518-1 No score
awstats vulnerability
It was discovered that AWStats incorrectly filtered certain parameters. A remote attacker could possibly use this issue to execute arbitrary code.
- Record
USN-3518-1- Updated
- 2026-11-02
OSVUSN-4953-1 No score
awstats vulnerabilities
Sean Boran discovered that AWStats incorrectly filtered certain parameters. A remote attacker could possibly use this issue to execute arbitrary code. (CVE-2020-29600)
It was discovered that AWStats incorrectly filtered certain parameters. A remote attacker could possibly use this issue to access sensitive information. (CVE-2020-35176)
- Record
USN-4953-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
awstatsAlpine:v3.10 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.11 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.12 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.13 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.14 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.15 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.16 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.17 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.18 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.19 |
before 7.6-r2 | 7.6-r2 |
Show 22 moreShow less
| Package | Affected | Fixed |
|---|---|---|
awstatsAlpine:v3.20 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.21 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.22 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.4 |
before 7.5-r2 | 7.5-r2 |
awstatsAlpine:v3.5 |
before 7.5-r2 | 7.5-r2 |
awstatsAlpine:v3.6 |
before 7.6-r1 | 7.6-r1 |
awstatsAlpine:v3.7 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.8 |
before 7.6-r2 | 7.6-r2 |
awstatsAlpine:v3.9 |
before 7.6-r2 | 7.6-r2 |
awstatsDebian:12 |
before 7.6+dfsg-2 | 7.6+dfsg-2 |
awstatsDebian:13 |
before 7.6+dfsg-2 | 7.6+dfsg-2 |
awstatsDebian:14 |
before 7.6+dfsg-2 | 7.6+dfsg-2 |
awstatsDebian:7 |
before 7.0~dfsg-7+deb7u1, plus listed versions 7.0~dfsg-7 |
7.0~dfsg-7+deb7u1 |
awstatsDebian:8 |
before 7.2+dfsg-1+deb8u1, plus listed versions 7.2+dfsg-1 |
7.2+dfsg-1+deb8u1 |
awstatsDebian:9 |
before 7.6+dfsg-1+deb9u1, plus listed versions 7.6+dfsg-1 |
7.6+dfsg-1+deb9u1 |
awstatsMageia:5 |
before 7.3-3.1.mga5 | 7.3-3.1.mga5 |
awstatsMageia:6 |
before 7.5-1.1.mga6 | 7.5-1.1.mga6 |
awstatsUbuntu:14.04:LTS |
before 7.2+dfsg-1ubuntu0.1, plus listed versions 7.1.1~dfsg-17.1.1~dfsg-27.2+dfsg-1 |
7.2+dfsg-1ubuntu0.1 |
awstatsUbuntu:16.04:LTS |
before 7.4+dfsg-1ubuntu0.2, plus listed versions 7.4+dfsg-17.4+dfsg-1ubuntu0.1 |
7.4+dfsg-1ubuntu0.2 |
awstatsUbuntu:Pro:16.04:LTS |
before 7.4+dfsg-1ubuntu0.4+esm1, plus listed versions 7.4+dfsg-17.4+dfsg-1ubuntu0.17.4+dfsg-1ubuntu0.27.4+dfsg-1ubuntu0.3 |
7.4+dfsg-1ubuntu0.4+esm1 |
awstatsUbuntu:18.04:LTS |
before 7.6+dfsg-2ubuntu0.18.04.1, plus listed versions 7.6+dfsg-17.6+dfsg-1ubuntu27.6+dfsg-2 |
7.6+dfsg-2ubuntu0.18.04.1 |
awstatsUbuntu:20.04:LTS |
before 7.6+dfsg-2ubuntu0.20.04.1, plus listed versions 7.6+dfsg-2 |
7.6+dfsg-2ubuntu0.20.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000501 is a critical vulnerability (CVSS 9.8) in Awstats, published January 3, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.35%, the 91st percentile. Fixed in awstats 7.6-r2.
References
debian.org/security/2018/dsa-4092
lists.debian.org/debian-lts-announce/2018/01/msg00012.html
github.com/eldy/awstats/commit/06c0ab29c1e5059d9e0279c6b64d573d619e1651
awstats.org
github.com/eldy/awstats/commit/cf219843a74c951bf5986f3a7fffa3dcf99c3899
security.gentoo.org/glsa/202007-37
Show 13 moreShow less
nvd.nist.gov/vuln/detail/CVE-2017-1000501
github.com/advisories/GHSA-ph65-4f3r-7fv8
security.alpinelinux.org/vuln/CVE-2017-1000501
security-tracker.debian.org/tracker/CVE-2017-1000501
advisories.mageia.org/MGASA-2018-0045.html
bugs.mageia.org/show_bug.cgi?id=22275
openwall.com/lists/oss-security/2017/12/29/1
ubuntu.com/security/CVE-2017-1000501
ubuntu.com/security/notices/USN-3518-1
cve.org/CVERecord?id=CVE-2017-1000501
ubuntu.com/security/notices/USN-4953-1
ubuntu.com/security/CVE-2020-29600
ubuntu.com/security/CVE-2020-35176