Every CVE Search/ Get API key

CVE-2017-1000501

Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the ...

9.8 CriticalFix available

Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.35%Up 1.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.

Record
CVE-2017-1000501
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.

Record
CVE-2017-1000501
Updated
2026-11-02
EUVDEUVD-2017-1610 No score

Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.

Record
EUVD-2017-1610
Updated
2026-11-03
GitHub AdvisoriesGHSA-ph65-4f3r-7fv8 9.8

Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the ...

Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.

Record
GHSA-ph65-4f3r-7fv8
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-22
Updated
2026-11-02
OSVALPINE-CVE-2017-1000501 9.8

Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.

Record
ALPINE-CVE-2017-1000501
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 9.8

Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.

Record
CVE-2017-1000501
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2017-1000501 9.8

Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.

Record
DEBIAN-CVE-2017-1000501
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-1000501 9.8

Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.

Record
UBUNTU-CVE-2017-1000501
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0045 No score

Updated awstats packages fix security vulnerability

The cPanel Security Team discovered two path traversal flaws in awstats in the "config" and "migrate" parameters that could be leveraged for unauthenticated remote code execution (CVE-2017-1000501).

Record
MGASA-2018-0045
Updated
2026-11-02
OSVUSN-3518-1 No score

awstats vulnerability

It was discovered that AWStats incorrectly filtered certain parameters. A remote attacker could possibly use this issue to execute arbitrary code.

Record
USN-3518-1
Updated
2026-11-02
OSVUSN-4953-1 No score

awstats vulnerabilities

Sean Boran discovered that AWStats incorrectly filtered certain parameters. A remote attacker could possibly use this issue to execute arbitrary code. (CVE-2020-29600)

It was discovered that AWStats incorrectly filtered certain parameters. A remote attacker could possibly use this issue to access sensitive information. (CVE-2020-35176)

Record
USN-4953-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
awstats
Alpine:v3.10
before 7.6-r2
7.6-r2
awstats
Alpine:v3.11
before 7.6-r2
7.6-r2
awstats
Alpine:v3.12
before 7.6-r2
7.6-r2
awstats
Alpine:v3.13
before 7.6-r2
7.6-r2
awstats
Alpine:v3.14
before 7.6-r2
7.6-r2
awstats
Alpine:v3.15
before 7.6-r2
7.6-r2
awstats
Alpine:v3.16
before 7.6-r2
7.6-r2
awstats
Alpine:v3.17
before 7.6-r2
7.6-r2
awstats
Alpine:v3.18
before 7.6-r2
7.6-r2
awstats
Alpine:v3.19
before 7.6-r2
7.6-r2
Show 22 moreShow less
Affected packages
PackageAffectedFixed
awstats
Alpine:v3.20
before 7.6-r2
7.6-r2
awstats
Alpine:v3.21
before 7.6-r2
7.6-r2
awstats
Alpine:v3.22
before 7.6-r2
7.6-r2
awstats
Alpine:v3.4
before 7.5-r2
7.5-r2
awstats
Alpine:v3.5
before 7.5-r2
7.5-r2
awstats
Alpine:v3.6
before 7.6-r1
7.6-r1
awstats
Alpine:v3.7
before 7.6-r2
7.6-r2
awstats
Alpine:v3.8
before 7.6-r2
7.6-r2
awstats
Alpine:v3.9
before 7.6-r2
7.6-r2
awstats
Debian:12
before 7.6+dfsg-2
7.6+dfsg-2
awstats
Debian:13
before 7.6+dfsg-2
7.6+dfsg-2
awstats
Debian:14
before 7.6+dfsg-2
7.6+dfsg-2
awstats
Debian:7
before 7.0~dfsg-7+deb7u1, plus listed versions
7.0~dfsg-7
7.0~dfsg-7+deb7u1
awstats
Debian:8
before 7.2+dfsg-1+deb8u1, plus listed versions
7.2+dfsg-1
7.2+dfsg-1+deb8u1
awstats
Debian:9
before 7.6+dfsg-1+deb9u1, plus listed versions
7.6+dfsg-1
7.6+dfsg-1+deb9u1
awstats
Mageia:5
before 7.3-3.1.mga5
7.3-3.1.mga5
awstats
Mageia:6
before 7.5-1.1.mga6
7.5-1.1.mga6
awstats
Ubuntu:14.04:LTS
before 7.2+dfsg-1ubuntu0.1, plus listed versions
7.1.1~dfsg-17.1.1~dfsg-27.2+dfsg-1
7.2+dfsg-1ubuntu0.1
awstats
Ubuntu:16.04:LTS
before 7.4+dfsg-1ubuntu0.2, plus listed versions
7.4+dfsg-17.4+dfsg-1ubuntu0.1
7.4+dfsg-1ubuntu0.2
awstats
Ubuntu:Pro:16.04:LTS
before 7.4+dfsg-1ubuntu0.4+esm1, plus listed versions
7.4+dfsg-17.4+dfsg-1ubuntu0.17.4+dfsg-1ubuntu0.27.4+dfsg-1ubuntu0.3
7.4+dfsg-1ubuntu0.4+esm1
awstats
Ubuntu:18.04:LTS
before 7.6+dfsg-2ubuntu0.18.04.1, plus listed versions
7.6+dfsg-17.6+dfsg-1ubuntu27.6+dfsg-2
7.6+dfsg-2ubuntu0.18.04.1
awstats
Ubuntu:20.04:LTS
before 7.6+dfsg-2ubuntu0.20.04.1, plus listed versions
7.6+dfsg-2
7.6+dfsg-2ubuntu0.20.04.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-1000501 is a critical vulnerability (CVSS 9.8) in Awstats, published January 3, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.35%, the 91st percentile. Fixed in awstats 7.6-r2.

References

Show 13 moreShow less
MoveEnter Open