CVE-2015-5714
Cross-site scripting (XSS) vulnerability in WordPress before 4.3.1 allows remote attackers to...
Cross-site scripting (XSS) vulnerability in WordPress before 4.3.1 allows remote attackers to inject arbitrary web script or HTML by leveraging the mishandling of unclosed HTML elements during processing of shortcode tags.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in WordPress before 4.3.1 allows remote attackers to inject arbitrary web script or HTML by leveraging the mishandling of unclosed HTML elements during processing of shortcode tags.
- Record
CVE-2015-5714- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in WordPress before 4.3.1 allows remote attackers to inject arbitrary web script or HTML by leveraging the mishandling of unclosed HTML elements during processing of shortcode tags.
- Record
CVE-2015-5714- Updated
- 2026-11-02
EUVDEUVD-2015-5661 No score
Cross-site scripting (XSS) vulnerability in WordPress before 4.3.1 allows remote attackers to inject arbitrary web script or HTML by leveraging the mishandling of unclosed HTML elements during processing of shortcode tags.
- Record
EUVD-2015-5661- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-92h3-fjv6-rmmc
6.1
Cross-site scripting (XSS) vulnerability in WordPress before 4.3.1 allows remote attackers to...
Cross-site scripting (XSS) vulnerability in WordPress before 4.3.1 allows remote attackers to inject arbitrary web script or HTML by leveraging the mishandling of unclosed HTML elements during processing of shortcode tags.
- Record
GHSA-92h3-fjv6-rmmc- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Cross-site scripting (XSS) vulnerability in WordPress before 4.3.1 allows remote attackers to inject arbitrary web script or HTML by leveraging the mishandling of unclosed HTML elements during processing of shortcode tags.
- Record
CVE-2015-5714- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-5714
6.1
Cross-site scripting (XSS) vulnerability in WordPress before 4.3.1 allows remote attackers to inject arbitrary web script or HTML by leveraging the mishandling of unclosed HTML elements during processing of shortcode tags.
- Record
DEBIAN-CVE-2015-5714- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-5714
6.1
Cross-site scripting (XSS) vulnerability in WordPress before 4.3.1 allows remote attackers to inject arbitrary web script or HTML by leveraging the mishandling of unclosed HTML elements during processing of shortcode tags.
- Record
UBUNTU-CVE-2015-5714- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVMGASA-2015-0377 No score
Updated wordpress package fixes security vulnerabilities
Updated wordpress packages fixes security vulnerabilities:
The wordpress package has been updated to version 3.9.9, fixing two cross-site scripting issues and a potential privilege escalation issue (CVE-2015-5714, CVE-2015-5715), as well as other bugs. See the upstream announcement and release notes for more details.
- Record
MGASA-2015-0377- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wordpressDebian:12 |
before 4.3.1+dfsg-1 | 4.3.1+dfsg-1 |
wordpressDebian:13 |
before 4.3.1+dfsg-1 | 4.3.1+dfsg-1 |
wordpressDebian:14 |
before 4.3.1+dfsg-1 | 4.3.1+dfsg-1 |
wordpressDebian:6.0 |
before 3.6.1+dfsg-1~deb6u8, plus listed versions 3.0.4+dfsg-13.0.5+dfsg-0+squeeze13.0.5+dfsg-13.2.1+dfsg-13.2.1+dfsg-2 Show 24 moreShow less3.2.1+dfsg-33.3+dfsg-13.3.1+dfsg-13.3.2+dfsg-13.3.2+dfsg-1~squeeze13.4+dfsg-13.4+dfsg-23.4+dfsg-33.4.1+dfsg-13.4.2+dfsg-13.5+dfsg-13.5.1+dfsg-13.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-13.6.1+dfsg-1~deb6u13.6.1+dfsg-1~deb6u23.6.1+dfsg-1~deb6u33.6.1+dfsg-1~deb6u43.6.1+dfsg-1~deb6u53.6.1+dfsg-1~deb6u63.6.1+dfsg-1~deb6u7 |
3.6.1+dfsg-1~deb6u8 |
wordpressDebian:8 |
before 4.1+dfsg-1+deb8u5, plus listed versions 4.1+dfsg-14.1+dfsg-1+deb8u14.1+dfsg-1+deb8u24.1+dfsg-1+deb8u34.1+dfsg-1+deb8u4 |
4.1+dfsg-1+deb8u5 |
wordpressDebian:7 |
before 3.6.1+dfsg-1~deb7u8, plus listed versions 3.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-1 Show 15 moreShow less3.6.1+dfsg-1~deb6u13.6.1+dfsg-1~deb6u23.6.1+dfsg-1~deb6u33.6.1+dfsg-1~deb6u43.6.1+dfsg-1~deb6u53.6.1+dfsg-1~deb6u63.6.1+dfsg-1~deb6u73.6.1+dfsg-1~deb6u83.6.1+dfsg-1~deb6u93.6.1+dfsg-1~deb7u13.6.1+dfsg-1~deb7u23.6.1+dfsg-1~deb7u33.6.1+dfsg-1~deb7u43.6.1+dfsg-1~deb7u53.6.1+dfsg-1~deb7u6 |
3.6.1+dfsg-1~deb7u8 |
wordpressMageia:4 |
before 3.9.9-1.mga4 | 3.9.9-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-5714 is a medium vulnerability (CVSS 6.1) in Wordpress, published September 17, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.94%, the 94th percentile. Fixed in wordpress 4.3.1+dfsg-1.
References
wpvulndb.com/vulnerabilities/8186
codex.wordpress.org/Version_4.3.1
debian.org/security/2015/dsa-3375
github.com/WordPress/WordPress/commit/f72b21af23da6b6d54208e5c1d65ececdaa109c8
wordpress.org/news/2015/09/wordpress-4-3-1
securitytracker.com/id/1033979
Show 10 moreShow less
debian.org/security/2015/dsa-3383
security-tracker.debian.org/tracker/CVE-2015-5714
securityfocus.com/bid/76745
nvd.nist.gov/vuln/detail/CVE-2015-5714
github.com/advisories/GHSA-92h3-fjv6-rmmc
advisories.mageia.org/MGASA-2015-0377.html
bugs.mageia.org/show_bug.cgi?id=16763
codex.wordpress.org/Version_3.9.9
ubuntu.com/security/CVE-2015-5714
cve.org/CVERecord?id=CVE-2015-5714