Every CVE Search/ Get API key

CVE-2016-0742

The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to cause a...

7.5 HighFix available

The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to cause a denial of service (invalid pointer dereference and worker process crash) via a crafted UDP DNS response.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

82.4%Up 80.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to cause a denial of service (invalid pointer dereference and worker process crash) via a crafted UDP DNS response.

Record
CVE-2016-0742
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to cause a denial of service (invalid pointer dereference and worker process crash) via a crafted UDP DNS response.

Record
CVE-2016-0742
Updated
2026-11-02
EUVDEUVD-2016-0765 No score

The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to cause a denial of service (invalid pointer dereference and worker process crash) via a crafted UDP DNS response.

Record
EUVD-2016-0765
Updated
2026-11-03
GitHub AdvisoriesGHSA-x98p-wfj9-8f25 7.5

The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to cause a...

The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to cause a denial of service (invalid pointer dereference and worker process crash) via a crafted UDP DNS response.

Record
GHSA-x98p-wfj9-8f25
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
OSV 7.5

The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to cause a denial of service (invalid pointer dereference and worker process crash) via a crafted UDP DNS response.

Record
CVE-2016-0742
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-0742 7.5

The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to cause a denial of service (invalid pointer dereference and worker process crash) via a crafted UDP DNS response.

Record
DEBIAN-CVE-2016-0742
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2016-0742 7.5

The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to cause a denial of service (invalid pointer dereference and worker process crash) via a crafted UDP DNS response.

Record
UBUNTU-CVE-2016-0742
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVMGASA-2016-0065 No score

Updated nginx packages fix security vulnerabilities

Updated nginx package fixes security vulnerabilities:

Several vulnerabilities were discovered in the resolver in nginx, leading to denial of service or, potentially, to arbitrary code execution. These only affect nginx if the "resolver" directive is used in a configuration file (CVE-2016-0742, CVE-2016-0746, CVE-2016-0747).

Record
MGASA-2016-0065
Updated
2026-11-02
OSVopenSUSE-SU-2024:10044-1 No score

nginx-1.11.4-2.5 on GA media

These are all security issues fixed in the nginx-1.11.4-2.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10044-1
Updated
2026-11-02
OSVSUSE-SU-2016:1232-1 No score

Security update for nginx-1.0

This update for nginx-1.0 fixes the following issues:

Security fixes:

  • CVE-2016-0742: Invalid pointer dereference during DNS server response processing
  • CVE-2016-0747: Resource exhaustion through unlimited CNAME resolution
  • CVE-2016-0746: Use-after-free condition during CNAME response processing
Record
SUSE-SU-2016:1232-1
Updated
2026-11-02
OSVUSN-2892-1 No score

nginx vulnerabilities

It was discovered that nginx incorrectly handled certain DNS server responses when the resolver is enabled. A remote attacker could possibly use this issue to cause nginx to crash, resulting in a denial of service. (CVE-2016-0742)

It was discovered that nginx incorrectly handled CNAME response processing when the resolver is enabled. A remote attacker could use this issue to cause nginx to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2016-0746)

It was discovered that nginx incorrectly handled CNAME resolution when the resolver is enabled. A remote attacker could possibly use this issue to cause nginx to consume resources, resulting in a denial of service. (CVE-2016-0747)

Record
USN-2892-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
nginx
Debian:12
before 1.9.10-1
1.9.10-1
nginx
Debian:13
before 1.9.10-1
1.9.10-1
nginx
Debian:14
before 1.9.10-1
1.9.10-1
nginx
Debian:6.0
before 0.7.67-3+squeeze4+deb6u1, plus listed versions
0.7.67-30.7.67-3+squeeze10.7.67-3+squeeze20.7.67-3+squeeze30.7.67-3+squeeze4
0.7.67-3+squeeze4+deb6u1
nginx
Debian:7
before 1.2.1-2.2+wheezy4, plus listed versions
1.2.1-2.21.2.1-2.2+wheezy11.2.1-2.2+wheezy21.2.1-2.2+wheezy31.2.1-2.2+wheezy3~bpo60+1
1.2.1-2.2+wheezy4
nginx
Debian:8
before 1.6.2-5+deb8u1, plus listed versions
1.6.2-51.6.2-5+a.exp11.6.2-5+deb8u1~bpo70+1
1.6.2-5+deb8u1
nginx
Mageia:5
before 1.6.2-5.1.mga5
1.6.2-5.1.mga5
rh-nginx18-nginx
Red Hat:rhel_software_collections:2::el6
before 1:1.8.1-1.el6
1:1.8.1-1.el6
rh-nginx18-nginx-debuginfo
Red Hat:rhel_software_collections:2::el6
before 1:1.8.1-1.el6
1:1.8.1-1.el6
rh-nginx18-nginx
Red Hat:rhel_software_collections:2::el7
before 1:1.8.1-1.el7
1:1.8.1-1.el7
Show 10 moreShow less
Affected packages
PackageAffectedFixed
rh-nginx18-nginx-debuginfo
Red Hat:rhel_software_collections:2::el7
before 1:1.8.1-1.el7
1:1.8.1-1.el7
GeoIP
SUSE:Lifecycle Management Server 1.3
before 1.4.7-2.10.1
1.4.7-2.10.1
nginx-1.0
SUSE:Lifecycle Management Server 1.3
before 1.0.15-0.29.2
1.0.15-0.29.2
GeoIP
SUSE:Studio Onsite 1.3
before 1.4.7-2.10.1
1.4.7-2.10.1
nginx-1.0
SUSE:Studio Onsite 1.3
before 1.0.15-0.29.2
1.0.15-0.29.2
GeoIP
SUSE:WebYast 1.3
before 1.4.7-2.10.1
1.4.7-2.10.1
nginx-1.0
SUSE:WebYast 1.3
before 1.0.15-0.29.2
1.0.15-0.29.2
nginx
Ubuntu:14.04:LTS
before 1.4.6-1ubuntu3.4, plus listed versions
1.4.1-3ubuntu11.4.3-2ubuntu11.4.4-1ubuntu11.4.4-2ubuntu11.4.4-4ubuntu1
Show 6 moreShow less
1.4.5-1ubuntu11.4.6-1ubuntu21.4.6-1ubuntu31.4.6-1ubuntu3.11.4.6-1ubuntu3.21.4.6-1ubuntu3.3
1.4.6-1ubuntu3.4
nginx
Ubuntu:16.04:LTS
before 1.9.10-0ubuntu1, plus listed versions
1.9.3-1ubuntu11.9.6-2ubuntu11.9.6-2ubuntu21.9.9-0ubuntu11.9.9-1ubuntu1
1.9.10-0ubuntu1
nginx
openSUSE:Tumbleweed
before 1.11.4-2.5
1.11.4-2.5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-0742 is a high vulnerability (CVSS 7.5) in F5 Nginx, published January 26, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 82.4%, the 99th percentile. Fixed in nginx 1.9.10-1.

References

Show 47 moreShow less
MoveEnter Open