bind9.16-devel vulnerabilities (AlmaLinux)
41 vulnerabilities.
-
bind9.16-develAlmaLinux Specific RPZ configurations and query patterns may result in an unexpected exit 7.5 High -
bind9.16-develAlmaLinux Named may terminate unexpectedly when a redirect zone is used with strict QNAME minimization 7.5 High -
bind9.16-develAlmaLinux Concurrent GSS-TSIG messages corrupt memory 8.1 High -
bind9.16-develAlmaLinux Amplified resource exhaustion in inbound message processing 7.5 High -
bind9.16-develAlmaLinux Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind9.16-develAlmaLinux Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind9.16-develAlmaLinux qpcache NOQNAME proof use-after-free crashes recursive resolver 5.9 Medium -
bind9.16-develAlmaLinux Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind9.16-develAlmaLinux DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind9.16-develAlmaLinux Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind9.16-develAlmaLinux Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bind9.16-develAlmaLinux Potential memory usage beyond configured limits 7.5 High -
bind9.16-develAlmaLinux Potential wildcard CNAME RPZ policy bypass 7.5 High -
bind9.16-develAlmaLinux Incorrect acceptance of NSEC3 records 6.8 Medium -
bind9.16-develAlmaLinux Invalid handling of CLASS != IN 7.5 High -
bind9.16-develAlmaLinux BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind9.16-develAlmaLinux Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind9.16-develAlmaLinux Cache poisoning due to weak PRNG 8.6 High -
bind9.16-develAlmaLinux Cache poisoning attacks with unsolicited RRs 8.6 High -
bind9.16-develAlmaLinux Many records in the additional section cause CPU exhaustion 7.5 High -
bind9.16-develAlmaLinux Assertion failure when serving both stale cache data and authoritative zone content 7.5 High -
bind9.16-develAlmaLinux SIG(0) can be used to exhaust CPU resources 7.5 High -
bind9.16-develAlmaLinux BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind9.16-develAlmaLinux Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bind9.16-develAlmaLinux Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution 7.5 High -
bind9.16-develAlmaLinux Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled 7.5 High -
bind9.16-develAlmaLinux The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind9.16-develAlmaLinux Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind9.16-develAlmaLinux Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind9.16-develAlmaLinux A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind9.16-develAlmaLinux named's configured cache size limit can be significantly exceeded 7.5 High -
bind9.16-develAlmaLinux named configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quota 7.5 High -
bind9.16-develAlmaLinux named configured to answer from stale cache may terminate unexpectedly while processing RRSIG queries 7.5 High -
bind9.16-develAlmaLinux An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind9.16-develAlmaLinux Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind9.16-develAlmaLinux Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind9.16-develAlmaLinux BIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate unexpectedly 7.5 High -
bind9.16-develAlmaLinux Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind9.16-develAlmaLinux bind9.16 bug fix and enhancement update No score -
bind9.16-develAlmaLinux DoS from specifically crafted TCP packets 5.3 Medium -
bind9.16-develAlmaLinux DNS forwarders - cache poisoning vulnerability 6.8 Medium