bind9.16-libs vulnerabilities (AlmaLinux)
41 vulnerabilities.
-
bind9.16-libsAlmaLinux Specific RPZ configurations and query patterns may result in an unexpected exit 7.5 High -
bind9.16-libsAlmaLinux Named may terminate unexpectedly when a redirect zone is used with strict QNAME minimization 7.5 High -
bind9.16-libsAlmaLinux Concurrent GSS-TSIG messages corrupt memory 8.1 High -
bind9.16-libsAlmaLinux Amplified resource exhaustion in inbound message processing 7.5 High -
bind9.16-libsAlmaLinux Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
bind9.16-libsAlmaLinux Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
bind9.16-libsAlmaLinux qpcache NOQNAME proof use-after-free crashes recursive resolver 5.9 Medium -
bind9.16-libsAlmaLinux Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
bind9.16-libsAlmaLinux DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
bind9.16-libsAlmaLinux Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
bind9.16-libsAlmaLinux Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
bind9.16-libsAlmaLinux Potential memory usage beyond configured limits 7.5 High -
bind9.16-libsAlmaLinux Potential wildcard CNAME RPZ policy bypass 7.5 High -
bind9.16-libsAlmaLinux Incorrect acceptance of NSEC3 records 6.8 Medium -
bind9.16-libsAlmaLinux Invalid handling of CLASS != IN 7.5 High -
bind9.16-libsAlmaLinux BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
bind9.16-libsAlmaLinux Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
bind9.16-libsAlmaLinux Cache poisoning due to weak PRNG 8.6 High -
bind9.16-libsAlmaLinux Cache poisoning attacks with unsolicited RRs 8.6 High -
bind9.16-libsAlmaLinux Many records in the additional section cause CPU exhaustion 7.5 High -
bind9.16-libsAlmaLinux Assertion failure when serving both stale cache data and authoritative zone content 7.5 High -
bind9.16-libsAlmaLinux SIG(0) can be used to exhaust CPU resources 7.5 High -
bind9.16-libsAlmaLinux BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
bind9.16-libsAlmaLinux Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
bind9.16-libsAlmaLinux Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution 7.5 High -
bind9.16-libsAlmaLinux Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled 7.5 High -
bind9.16-libsAlmaLinux The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
bind9.16-libsAlmaLinux Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
bind9.16-libsAlmaLinux Parsing large DNS messages may cause excessive CPU load 7.5 High -
bind9.16-libsAlmaLinux A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
bind9.16-libsAlmaLinux named's configured cache size limit can be significantly exceeded 7.5 High -
bind9.16-libsAlmaLinux named configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quota 7.5 High -
bind9.16-libsAlmaLinux named configured to answer from stale cache may terminate unexpectedly while processing RRSIG queries 7.5 High -
bind9.16-libsAlmaLinux An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
bind9.16-libsAlmaLinux Memory leaks in EdDSA DNSSEC verification code 7.5 High -
bind9.16-libsAlmaLinux Memory leak in ECDSA DNSSEC verification code 7.5 High -
bind9.16-libsAlmaLinux BIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate unexpectedly 7.5 High -
bind9.16-libsAlmaLinux Processing large delegations may severely degrade resolver performance 5.3 Medium -
bind9.16-libsAlmaLinux bind9.16 bug fix and enhancement update No score -
bind9.16-libsAlmaLinux DoS from specifically crafted TCP packets 5.3 Medium -
bind9.16-libsAlmaLinux DNS forwarders - cache poisoning vulnerability 6.8 Medium