python3-bind vulnerabilities (AlmaLinux)
43 vulnerabilities.
-
python3-bindAlmaLinux Specific RPZ configurations and query patterns may result in an unexpected exit 7.5 High -
python3-bindAlmaLinux Named may terminate unexpectedly when a redirect zone is used with strict QNAME minimization 7.5 High -
python3-bindAlmaLinux Concurrent GSS-TSIG messages corrupt memory 8.1 High -
python3-bindAlmaLinux Amplified resource exhaustion in inbound message processing 7.5 High -
python3-bindAlmaLinux Validating resolver can abort while caching a mismatched NOQNAME proof 7.5 High -
python3-bindAlmaLinux Use-after-free in query_addnoqnameproof() via the DNS64 filter64 path 7.5 High -
python3-bindAlmaLinux qpcache NOQNAME proof use-after-free crashes recursive resolver 5.9 Medium -
python3-bindAlmaLinux Remote assertion failure via 16-bit length truncation in `dns_ncache_add()` 7.5 High -
python3-bindAlmaLinux DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 High -
python3-bindAlmaLinux Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 High -
python3-bindAlmaLinux Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 High -
python3-bindAlmaLinux Potential memory usage beyond configured limits 7.5 High -
python3-bindAlmaLinux Potential wildcard CNAME RPZ policy bypass 7.5 High -
python3-bindAlmaLinux Incorrect acceptance of NSEC3 records 6.8 Medium -
python3-bindAlmaLinux Invalid handling of CLASS != IN 7.5 High -
python3-bindAlmaLinux BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 High -
python3-bindAlmaLinux Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 High -
python3-bindAlmaLinux Resource exhaustion via malformed DNSKEY handling 7.5 High -
python3-bindAlmaLinux Cache poisoning due to weak PRNG 8.6 High -
python3-bindAlmaLinux Cache poisoning attacks with unsolicited RRs 8.6 High -
python3-bindAlmaLinux Many records in the additional section cause CPU exhaustion 7.5 High -
python3-bindAlmaLinux Assertion failure when serving both stale cache data and authoritative zone content 7.5 High -
python3-bindAlmaLinux SIG(0) can be used to exhaust CPU resources 7.5 High -
python3-bindAlmaLinux BIND's database will be slow if a very large number of RRs exist at the same name 7.5 High -
python3-bindAlmaLinux Specific recursive query patterns may lead to an out-of-memory condition 7.5 High -
python3-bindAlmaLinux Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution 7.5 High -
python3-bindAlmaLinux Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled 7.5 High -
python3-bindAlmaLinux The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
python3-bindAlmaLinux Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
python3-bindAlmaLinux Parsing large DNS messages may cause excessive CPU load 7.5 High -
python3-bindAlmaLinux A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 High -
python3-bindAlmaLinux named's configured cache size limit can be significantly exceeded 7.5 High -
python3-bindAlmaLinux named configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quota 7.5 High -
python3-bindAlmaLinux named configured to answer from stale cache may terminate unexpectedly while processing RRSIG queries 7.5 High -
python3-bindAlmaLinux An UPDATE message flood may cause named to exhaust all available memory 7.5 High -
python3-bindAlmaLinux Memory leaks in EdDSA DNSSEC verification code 7.5 High -
python3-bindAlmaLinux Memory leak in ECDSA DNSSEC verification code 7.5 High -
python3-bindAlmaLinux BIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate unexpectedly 7.5 High -
python3-bindAlmaLinux Processing large delegations may severely degrade resolver performance 5.3 Medium -
python3-bindAlmaLinux DoS from specifically crafted TCP packets 5.3 Medium -
python3-bindAlmaLinux DNS forwarders - cache poisoning vulnerability 6.8 Medium -
python3-bindAlmaLinux Lame cache can be abused to severely degrade resolver performance 5.3 Medium -
python3-bindAlmaLinux A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 Medium