bind vulnerabilities (Alpine)
114 vulnerabilities.
bindAlpineCleaning an ECS-enabled cache may cause excessive CPU load5.3 MediumbindAlpineSpecific recursive query patterns may lead to an out-of-memory condition7.5 HighbindAlpineEnabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution7.5 HighbindAlpineQuerying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled7.5 HighbindAlpineThe Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is...7.5 HighbindAlpineCertain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers...7.5 HighbindAlpineParsing large DNS messages may cause excessive CPU load7.5 HighbindAlpinenamed may terminate unexpectedly under high DNS-over-TLS query load7.5 HighbindAlpineA stack exhaustion flaw in control channel code may cause named to terminate unexpectedly7.5 HighbindAlpineExceeding the recursive-clients quota may cause named to terminate unexpectedly when stale-answer-client-timeout is set to 07.5 HighbindAlpinenamed configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quota7.5 HighbindAlpinenamed configured to answer from stale cache may terminate unexpectedly while processing RRSIG queries7.5 HighbindAlpineAn UPDATE message flood may cause named to exhaust all available memory7.5 HighbindAlpineMemory leaks in EdDSA DNSSEC verification code7.5 HighbindAlpineMemory leak in ECDSA DNSSEC verification code7.5 HighbindAlpineBIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate unexpectedly7.5 HighbindAlpineMemory leaks in code handling Diffie-Hellman key exchange via TKEY RRs (OpenSSL 3.0.0+ only)7.5 HighbindAlpineBuffer overread in statistics channel code5.5 MediumbindAlpineProcessing large delegations may severely degrade resolver performance5.3 MediumbindAlpineDoS from specifically crafted TCP packets5.3 MediumbindAlpineDNS forwarders - cache poisoning vulnerability6.8 MediumbindAlpineLame cache can be abused to severely degrade resolver performance5.3 MediumbindAlpineA too-strict assertion check could be triggered when responses in BIND 9.16.19 and 9.17.16 require UDP fragmentation if RRL is in use7.5 HighbindAlpineA second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack8.1 HighbindAlpineAn assertion check can fail while answering queries for DNAME records that require the DNAME to be processed to resolve itself7.5 HighbindAlpineA broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly6.5 MediumbindAlpineA vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack8.1 HighbindAlpineupdate-policy rules of type "subdomain" are enforced incorrectly4.3 MediumbindAlpineA flaw in native PKCS#11 code can lead to a remotely triggerable assertion failure in pk11.c7.5 HighbindAlpineA truncated TSIG response can lead to an assertion failure6.5 MediumbindAlpineAttempting QNAME minimization after forwarding can lead to an assertion failure in resolver.c7.5 HighbindAlpineIn BIND 9.15.6 -> 9.16.5, 9.17.0 -> 9.17.3, An attacker who can establish a TCP connection with...7.5 HighbindAlpineA buffer boundary check assertion in rdataset.c can fail incorrectly during zone transfer4.9 MediumbindAlpineA buffer boundary check assertion in rdataset.c can fail incorrectly during zone transfer4.9 MediumbindAlpineA logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c7.5 HighbindAlpineBIND does not sufficiently limit the number of fetches performed when processing referrals8.6 HighbindAlpineTCP-pipelined queries can bypass tcp-clients limit7.5 HighbindAlpineAn error in QNAME minimization code can cause BIND to exit with an assertion failure5.9 MediumbindAlpineA flaw in mirror zone validity checking can allow zone data to be spoofed5.9 MediumbindAlpineA race condition when discarding malformed packets can cause BIND to exit with an assertion failure5.9 MediumbindAlpineAn error in the nxdomain redirect feature can cause BIND to exit with an INSIST assertion failure in query.c5.9 MediumbindAlpineLimiting simultaneous TCP clients was ineffective7.5 HighbindAlpineZone transfer controls for writable DLZ zones were not effective5.3 MediumbindAlpineAn assertion failure can occur if a trust anchor rolls over to an unsupported key algorithm when using managed-keys4.9 MediumbindAlpineA specially crafted packet can cause named to leak memory7.5 HighbindAlpineUpdate policies krb5-subdomain and ms-subdomain do not enforce controls promised in their documentation6.5 MediumbindAlpineBIND 9.12's serve-stale implementation can cause an assertion failure in rbtdb.c or other undesirable behavior, even if serve-stale is not enabled.5.9 MediumbindAlpineAn error in zone database reference counting can lead to an assertion failure if a server which...5.3 MediumbindAlpineWindows service and uninstall paths are not quoted when BIND is installed7.2 HighbindAlpineAn error processing RPZ rules can cause named to loop endlessly after handling a query3.7 Low- Show moreLoading…