pdns-recursor vulnerabilities (Alpine)
35 vulnerabilities.
-
pdns-recursorAlpine RRSIGs with too few labels can lead to bypass of DNSSEC wildcard validation 7.5 High -
pdns-recursorAlpine Wildcard CNAME proof validation bypass 3.7 Low -
pdns-recursorAlpine Spoofed answers can mark an authoritative non-EDNS capable 5.9 Medium -
pdns-recursorAlpine Insufficient input validation in ZoneToCache 5.9 Medium -
pdns-recursorAlpine Information about ECS zero scoped answers might leak to clients that use a specific ECS 5.3 Medium -
pdns-recursorAlpine ZoneToCache can poison the cache 7.5 High -
pdns-recursorAlpine Insufficient input validation of internal web server 4.3 Medium -
pdns-recursorAlpine Insufficient validation of cookie reply 5.9 Medium -
pdns-recursorAlpine Null pointer accces in aggressive NSEC(3) cache 5.9 Medium -
pdns-recursorAlpine Concurrent modification of RPZ data can lead to denial of servce 5.0 Medium -
pdns-recursorAlpine Crafted zones can cause increased resource usage 5.3 Medium -
pdns-recursorAlpine Unbounded memory allocation by internal web server 5.3 Medium -
pdns-recursorAlpine Insufficient validation of zonemd record 4.4 Medium -
pdns-recursorAlpine Null pointer dereference in RPZ transfer 4.4 Medium -
pdns-recursorAlpine Crafted zones can lead to increased incoming network traffic 5.3 Medium -
pdns-recursorAlpine Crafted zones can lead to increased resource usage and crafted CNAME chains can lead to cache poisoning in Recursor 5.3 Medium -
pdns-recursorAlpine Internal logic flaw in cache management can lead to a denial of service in PowerDNS Recursor 5.3 Medium -
pdns-recursorAlpine Insufficient validation of incoming notifies over TCP can lead to a denial of service in Recursor 7.5 High -
pdns-recursorAlpine Crafted delegations or IP fragments can poison cached delegations in Recursor 6.5 Medium -
pdns-recursorAlpine Crafted delegations or IP fragments can poison cached delegations in Recursor 8.2 High -
pdns-recursorAlpine A Recursor configured to send out ECS enabled queries can be sensitive to spoofing attempts 7.5 High -
pdns-recursorAlpine A crafted zone can lead to an illegal memory access in the PowerDNS Recursor 7.5 High -
pdns-recursorAlpine Crafted responses can lead to a denial of service in Recursor if recursive forwarding is configured 7.5 High -
pdns-recursorAlpine The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
pdns-recursorAlpine Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
pdns-recursorAlpine A remote attacker might be able to cause infinite recursion in PowerDNS Recursor 4.8.0 via a DNS... 7.5 High -
pdns-recursorAlpine PowerDNS Recursor up to and including 4.5.9, 4.6.2 and 4.7.1, when protobuf logging is enabled,... 6.5 Medium -
pdns-recursorAlpine In PowerDNS Authoritative Server before 4.4.3, 4.5.x before 4.5.4, and 4.6.x before 4.6.1 and... 7.5 High -
pdns-recursorAlpine An issue has been found in PowerDNS Recursor before 4.1.18, 4.2.x before 4.2.5, and 4.3.x before... 7.5 High -
pdns-recursorAlpine In PowerDNS Recursor versions up to and including 4.3.1, 4.2.2 and 4.1.16, the ACL restricting... 5.3 Medium -
pdns-recursorAlpine An issue has been found in PowerDNS Recursor 4.1.0 through 4.3.0 where records in the answer... 7.5 High -
pdns-recursorAlpine PowerDNS Recursor from 4.1.0 up to and including 4.3.0 does not sufficiently defend against... 7.5 High -
pdns-recursorAlpine An issue has been found in PowerDNS Recursor 4.1.0 up to and including 4.3.0. It allows an... 8.8 High -
pdns-recursorAlpine An issue has been found in PowerDNS Recursor versions 4.1.x before 4.1.9 where records in the... 3.7 Low -
pdns-recursorAlpine An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks... 5.4 Medium