pdns-recursor vulnerabilities (Debian)
76 vulnerabilities.
-
pdns-recursorDebian [DNSSEC validation bypass and cache poisoning in PowerDNS Recursor via out-of-band NS resolution] No score -
pdns-recursorDebian [A malicious client can cause too many TCP connections in TIME_WAIT state] No score -
pdns-recursorDebian [Recursor retains closed TCP client addresses until process exit] No score -
pdns-recursorDebian [Single web client not doing TLS handshake monopolizes web access] No score -
pdns-recursorDebian [Missing OPT RR owner-name validation bypasses ECS hardening] No score -
pdns-recursorDebian [A crafted DNS packet can cause a denial of service decompressing the DNS names in the packet] No score -
pdns-recursorDebian [Out-of-bounds read in Recursor findScopeZero] No score -
pdns-recursorDebian [A crafted DNS packet can cause increased memory and CPU consumption] No score -
pdns-recursorDebian RRSIGs with too few labels can lead to bypass of DNSSEC wildcard validation 7.5 High -
pdns-recursorDebian Wildcard CNAME proof validation bypass 3.7 Low -
pdns-recursorDebian Prefetch Feature Allows Persistent Ghost Domain Cache Poisoning Attack 3.7 Low -
pdns-recursorDebian Reject more queries with invalid header values 5.3 Medium -
pdns-recursorDebian Spoofed answers can mark an authoritative non-EDNS capable 5.9 Medium -
pdns-recursorDebian ZONEMD validation can be bypassed 5.3 Medium -
pdns-recursorDebian Missing input validation for catalog zones 5.9 Medium -
pdns-recursorDebian Insufficient input validation in ZoneToCache 5.9 Medium -
pdns-recursorDebian Information about ECS zero scoped answers might leak to clients that use a specific ECS 5.3 Medium -
pdns-recursorDebian ZoneToCache can poison the cache 7.5 High -
pdns-recursorDebian Insufficient input validation of internal web server 4.3 Medium -
pdns-recursorDebian Insufficient validation of cookie reply 5.9 Medium -
pdns-recursorDebian Null pointer accces in aggressive NSEC(3) cache 5.9 Medium -
pdns-recursorDebian Insufficient input validation of internal webserver 5.3 Medium -
pdns-recursorDebian Concurrent modification of RPZ data can lead to denial of servce 5.0 Medium -
pdns-recursorDebian Crafted zones can cause increased resource usage 5.3 Medium -
pdns-recursorDebian Insufficient input validation of internal webserver 5.3 Medium -
pdns-recursorDebian Unbounded memory allocation by internal web server 5.3 Medium -
pdns-recursorDebian Insufficient validation of zonemd record 4.4 Medium -
pdns-recursorDebian Null pointer dereference in RPZ transfer 4.4 Medium -
pdns-recursorDebian Crafted zones can lead to increased incoming network traffic 5.3 Medium -
pdns-recursorDebian Crafted zones can lead to increased resource usage and crafted CNAME chains can lead to cache poisoning in Recursor 5.3 Medium -
pdns-recursorDebian Internal logic flaw in cache management can lead to a denial of service in PowerDNS Recursor 5.3 Medium -
pdns-recursorDebian Insufficient validation of incoming notifies over TCP can lead to a denial of service in Recursor 7.5 High -
pdns-recursorDebian Crafted delegations or IP fragments can poison cached delegations in Recursor 6.5 Medium -
pdns-recursorDebian Crafted delegations or IP fragments can poison cached delegations in Recursor 8.2 High -
pdns-recursorDebian A Recursor configured to send out ECS enabled queries can be sensitive to spoofing attempts 7.5 High -
pdns-recursorDebian A crafted zone can lead to an illegal memory access in the PowerDNS Recursor 7.5 High -
pdns-recursorDebian Crafted responses can lead to a denial of service due to cache inefficiencies in the Recursor 7.5 High -
pdns-recursorDebian Crafted responses can lead to a denial of service in Recursor if recursive forwarding is configured 7.5 High -
pdns-recursorDebian pdns-recursor - regression update No score -
pdns-recursorDebian The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is... 7.5 High -
pdns-recursorDebian Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers... 7.5 High -
pdns-recursorDebian Deterred spoofing attempts can lead to authoritative servers being marked unavailable 3.4 Low -
pdns-recursorDebian A remote attacker might be able to cause infinite recursion in PowerDNS Recursor 4.8.0 via a DNS... 7.5 High -
pdns-recursorDebian PowerDNS Recursor up to and including 4.5.9, 4.6.2 and 4.7.1, when protobuf logging is enabled,... 6.5 Medium -
pdns-recursorDebian In PowerDNS Authoritative Server before 4.4.3, 4.5.x before 4.5.4, and 4.6.x before 4.6.1 and... 7.5 High -
pdns-recursorDebian An issue has been found in PowerDNS Recursor before 4.1.18, 4.2.x before 4.2.5, and 4.3.x before... 7.5 High -
pdns-recursorDebian In PowerDNS Recursor versions up to and including 4.3.1, 4.2.2 and 4.1.16, the ACL restricting... 5.3 Medium -
pdns-recursorDebian An issue has been found in PowerDNS Recursor 4.1.0 through 4.3.0 where records in the answer... 7.5 High -
pdns-recursorDebian PowerDNS Recursor from 4.1.0 up to and including 4.3.0 does not sufficiently defend against... 7.5 High -
pdns-recursorDebian An issue has been found in PowerDNS Recursor 4.1.0 up to and including 4.3.0. It allows an... 8.8 High - Show olderLoading…