Skip to content
Powerdns Recursor vulnerabilities
-
powerdns recursor
RRSIGs with too few labels can lead to bypass of DNSSEC wildcard validation
CVE-2026-52688
Fix available
7.5 High
-
powerdns recursor
Wildcard CNAME proof validation bypass
CVE-2026-52686
Fix available
3.7 Low
-
powerdns recursor
Prefetch Feature Allows Persistent Ghost Domain Cache Poisoning Attack
CVE-2026-52684
3.7 Low
-
powerdns recursor
Reject more queries with invalid header values
CVE-2026-42389
Fix available
5.3 Medium
-
powerdns recursor
Spoofed answers can mark an authoritative non-EDNS capable
CVE-2026-52690
Fix available
5.9 Medium
-
powerdns recursor
ZONEMD validation can be bypassed
CVE-2026-42390
Fix available
5.3 Medium
-
powerdns recursor
Missing input validation for catalog zones
CVE-2026-42388
Fix available
5.9 Medium
-
powerdns recursor
Insufficient input validation in ZoneToCache
CVE-2026-42387
Fix available
5.9 Medium
-
powerdns recursor
Information about ECS zero scoped answers might leak to clients that use a specific ECS
CVE-2026-40012
Fix available
5.3 Medium
-
powerdns recursor
ZoneToCache can poison the cache
CVE-2026-33612
Fix available
7.5 High
-
powerdns recursor
Insufficient validation of cookie reply
CVE-2026-33262
Fix available
5.9 Medium
-
powerdns recursor
Null pointer accces in aggressive NSEC(3) cache
CVE-2026-33261
Fix available
5.9 Medium
-
powerdns authoritative, dnsdist, recursor +2 more
Insufficient input validation of internal webserver
CVE-2026-33260
Fix available
5.3 Medium
-
powerdns recursor
Concurrent modification of RPZ data can lead to denial of servce
CVE-2026-33259
Fix available
5.0 Medium
-
powerdns recursor
Crafted zones can cause increased resource usage
CVE-2026-33258
Fix available
5.3 Medium
-
powerdns authoritative, dnsdist, recursor +2 more
Insufficient input validation of internal webserver
CVE-2026-33257
Fix available
5.3 Medium
-
powerdns recursor
Unbounded memory allocation by internal web server
CVE-2026-33256
Fix available
5.3 Medium
-
powerdns recursor
Insufficient validation of zonemd record
CVE-2026-33601
Fix available
4.4 Medium
-
powerdns recursor
Null pointer dereference in RPZ transfer
CVE-2026-33600
Fix available
4.4 Medium
-
powerdns recursor
Crafted zones can lead to increased incoming network traffic
CVE-2026-24027
Fix available
5.3 Medium
-
powerdns recursor
Crafted zones can lead to increased resource usage and crafted CNAME chains can lead to cache poisoning in Recursor
CVE-2026-0398
Fix available
5.3 Medium
-
powerdns recursor
Internal logic flaw in cache management can lead to a denial of service in PowerDNS Recursor
CVE-2025-59029
Fix available
5.3 Medium
-
powerdns recursor
Insufficient validation of incoming notifies over TCP can lead to a denial of service in Recursor
CVE-2025-59030
Fix available
7.5 High
-
powerdns recursor
Crafted delegations or IP fragments can poison cached delegations in Recursor
CVE-2025-59024
Fix available
6.5 Medium
-
powerdns recursor
Crafted delegations or IP fragments can poison cached delegations in Recursor
CVE-2025-59023
Fix available
8.2 High
-
powerdns recursor
A Recursor configured to send out ECS enabled queries can be sensitive to spoofing attempts
CVE-2025-30192
Fix available
7.5 High
-
powerdns recursor
A crafted zone can lead to an illegal memory access in the PowerDNS Recursor
CVE-2025-30195
Fix available
7.5 High
-
powerdns recursor
Crafted responses can lead to a denial of service due to cache inefficiencies in the Recursor
CVE-2024-25590
Fix available
7.5 High
-
powerdns recursor, powerdns +1 more
Crafted responses can lead to a denial of service in Recursor if recursive forwarding is configured
CVE-2024-25583
Fix available
7.5 High
-
debian linux, fedoraproject fedora, isc bind +5 more +7 more
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is...
CVE-2023-50868
Public exploitFix available
EPSS 74.3%
7.5 High
-
fedoraproject fedora, isc bind, microsoft windows server 2008 +10 more +12 more
Certain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers...
CVE-2023-50387
Public exploitFix available
EPSS 100.0%
7.5 High
-
powerdns recursor
Deterred spoofing attempts can lead to authoritative servers being marked unavailable
CVE-2023-26437
Fix available
3.4 Low
-
powerdns recursor
A remote attacker might be able to cause infinite recursion in PowerDNS Recursor 4.8.0 via a DNS...
CVE-2023-22617
Fix available
7.5 High
-
powerdns recursor, fedoraproject fedora +1 more
PowerDNS Recursor up to and including 4.5.9, 4.6.2 and 4.7.1, when protobuf logging is enabled,...
CVE-2022-37428
Fix available
6.5 Medium
-
powerdns authoritative server, recursor, fedoraproject fedora +2 more
In PowerDNS Authoritative Server before 4.4.3, 4.5.x before 4.5.4, and 4.6.x before 4.6.1 and...
CVE-2022-27227
Fix available
7.5 High
-
powerdns recursor, opensuse backports sle, leap +2 more
An issue has been found in PowerDNS Recursor before 4.1.18, 4.2.x before 4.2.5, and 4.3.x before...
CVE-2020-25829
Fix available
7.5 High
-
powerdns recursor
In PowerDNS Recursor versions up to and including 4.3.1, 4.2.2 and 4.1.16, the ACL restricting...
CVE-2020-14196
Fix available
5.3 Medium
-
powerdns recursor, debian linux, fedoraproject fedora +2 more +4 more
An issue has been found in PowerDNS Recursor 4.1.0 through 4.3.0 where records in the answer...
CVE-2020-12244
Fix available
7.5 High
-
powerdns recursor, debian linux, fedoraproject fedora +2 more +4 more
PowerDNS Recursor from 4.1.0 up to and including 4.3.0 does not sufficiently defend against...
CVE-2020-10995
Fix available
7.5 High
-
powerdns recursor
An issue has been found in PowerDNS Recursor 4.1.0 up to and including 4.3.0. It allows an...
CVE-2020-10030
Fix available
EPSS 24.5%
8.8 High
-
powerdns recursor, power dns pdns-recursor +1 more
An issue has been found in PowerDNS Recursor versions 4.1.x before 4.1.9 where records in the...
CVE-2019-3807
Fix available
3.7 Low
-
powerdns recursor, power dns pdns-recursor +1 more
An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks...
CVE-2019-3806
Fix available
5.4 Medium
-
powerdns recursor, [unknown] pdns-recursor +1 more
An issue has been found in PowerDNS Recursor before version 4.1.8 where a remote attacker sending...
CVE-2018-16855
Fix available
EPSS 58.6%
7.5 High
-
powerdns authoritative, recursor, debian pdns +1 more +3 more
PowerDNS Authoritative Server 4.1.0 up to 4.1.4 inclusive and PowerDNS Recursor 4.0.0 up to 4.1.4...
CVE-2018-14626
Fix available
5.3 Medium
-
powerdns authoritative, recursor, debian pdns +1 more +3 more
PowerDNS Authoritative Server 3.3.0 up to 4.1.4 excluding 4.1.5 and 4.0.6, and PowerDNS Recursor...
CVE-2018-10851
Fix available
5.3 Medium
-
powerdns recursor, [unknown] pdns +1 more
An issue has been found in PowerDNS Recursor from 4.0.0 up to and including 4.1.4. A remote...
CVE-2018-14644
Fix available
5.3 Medium
-
powerdns recursor
An issue has been found in the DNSSEC parsing code of PowerDNS Recursor from 4.0.0 up to and...
CVE-2017-15094
Fix available
5.9 Medium
-
powerdns recursor
When api-config-dir is set to a non-empty value, which is not the case by default, the API in...
CVE-2017-15093
Fix available
5.3 Medium
-
powerdns recursor
A cross-site scripting issue has been found in the web interface of PowerDNS Recursor from 4.0.0...
CVE-2017-15092
Fix available
6.1 Medium
-
powerdns, powerdns recursor +1 more
An issue has been found in the DNSSEC validation component of PowerDNS Recursor from 4.0.0 and up...
CVE-2017-15090
Fix available
5.9 Medium
- Show olderLoading…