bind9 vulnerabilities (Debian)
163 vulnerabilities.
bind9DebianSpecific recursive query patterns may lead to an out-of-memory condition7.5 Highbind9DebianEnabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution7.5 Highbind9DebianQuerying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled7.5 Highbind9DebianThe Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is...7.5 Highbind9DebianCertain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers...7.5 Highbind9DebianParsing large DNS messages may cause excessive CPU load7.5 Highbind9Debiannamed may terminate unexpectedly under high DNS-over-TLS query load7.5 Highbind9DebianA stack exhaustion flaw in control channel code may cause named to terminate unexpectedly7.5 Highbind9DebianExceeding the recursive-clients quota may cause named to terminate unexpectedly when stale-answer-client-timeout is set to 07.5 Highbind9Debiannamed's configured cache size limit can be significantly exceeded7.5 Highbind9Debiannamed configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quota7.5 Highbind9Debiannamed configured to answer from stale cache may terminate unexpectedly while processing RRSIG queries7.5 Highbind9DebianAn UPDATE message flood may cause named to exhaust all available memory7.5 Highbind9DebianMemory leaks in EdDSA DNSSEC verification code7.5 Highbind9DebianMemory leak in ECDSA DNSSEC verification code7.5 Highbind9DebianBIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate unexpectedly7.5 Highbind9DebianMemory leaks in code handling Diffie-Hellman key exchange via TKEY RRs (OpenSSL 3.0.0+ only)7.5 Highbind9DebianBuffer overread in statistics channel code5.5 Mediumbind9DebianProcessing large delegations may severely degrade resolver performance5.3 Mediumbind9DebianDestroying a TLS session early causes assertion failure7.5 Highbind9Debianbind9 - regression updateNo scorebind9DebianAssertion failure on delayed DS lookup7.5 Highbind9DebianVersions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific...7.5 Highbind9DebianDoS from specifically crafted TCP packets5.3 Mediumbind9DebianDNS forwarders - cache poisoning vulnerability6.8 Mediumbind9DebianLame cache can be abused to severely degrade resolver performance5.3 Mediumbind9DebianA second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack8.1 Highbind9DebianAn assertion check can fail while answering queries for DNAME records that require the DNAME to be processed to resolve itself7.5 Highbind9DebianA broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly6.5 Mediumbind9DebianA vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack8.1 Highbind9Debianupdate-policy rules of type "subdomain" are enforced incorrectly4.3 Mediumbind9DebianA flaw in native PKCS#11 code can lead to a remotely triggerable assertion failure in pk11.c7.5 Highbind9DebianA truncated TSIG response can lead to an assertion failure6.5 Mediumbind9DebianAttempting QNAME minimization after forwarding can lead to an assertion failure in resolver.c7.5 Highbind9DebianIn BIND 9.15.6 -> 9.16.5, 9.17.0 -> 9.17.3, An attacker who can establish a TCP connection with...7.5 Highbind9DebianA buffer boundary check assertion in rdataset.c can fail incorrectly during zone transfer4.9 Mediumbind9DebianA buffer boundary check assertion in rdataset.c can fail incorrectly during zone transfer4.9 Mediumbind9DebianA logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c7.5 Highbind9DebianBIND does not sufficiently limit the number of fetches performed when processing referrals8.6 Highbind9DebianTCP-pipelined queries can bypass tcp-clients limit7.5 Highbind9DebianA race condition when discarding malformed packets can cause BIND to exit with an assertion failure5.9 Mediumbind9DebianLimiting simultaneous TCP clients was ineffective7.5 Highbind9DebianZone transfer controls for writable DLZ zones were not effective5.3 Mediumbind9DebianAn assertion failure can occur if a trust anchor rolls over to an unsupported key algorithm when using managed-keys4.9 Mediumbind9DebianA specially crafted packet can cause named to leak memory7.5 Highbind9DebianUpdate policies krb5-subdomain and ms-subdomain do not enforce controls promised in their documentation6.5 Mediumbind9DebianA flaw in the "deny-answer-aliases" feature can cause an assertion failure in named7.5 Highbind9DebianSome versions of BIND can improperly permit recursive query service to unauthorized clients5.3 Mediumbind9DebianBackport of the fix for CVE-2017-3137 leads to assertion failure in validator.c:18587.5 Highbind9DebianImproper fetch cleanup sequencing in the resolver can cause named to crash7.5 High- Show moreLoading…