bind9 vulnerabilities (Ubuntu)
120 vulnerabilities.
bind9UbuntuQuerying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled7.5 Highbind9UbuntuThe Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is...7.5 Highbind9UbuntuCertain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers...7.5 Highbind9UbuntuParsing large DNS messages may cause excessive CPU load7.5 Highbind9Ubuntunamed may terminate unexpectedly under high DNS-over-TLS query load7.5 Highbind9UbuntuA stack exhaustion flaw in control channel code may cause named to terminate unexpectedly7.5 Highbind9UbuntuExceeding the recursive-clients quota may cause named to terminate unexpectedly when stale-answer-client-timeout is set to 07.5 Highbind9Ubuntunamed's configured cache size limit can be significantly exceeded7.5 Highbind9Ubuntunamed configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quota7.5 Highbind9Ubuntunamed configured to answer from stale cache may terminate unexpectedly while processing RRSIG queries7.5 Highbind9UbuntuAn UPDATE message flood may cause named to exhaust all available memory7.5 Highbind9UbuntuMemory leaks in EdDSA DNSSEC verification code7.5 Highbind9UbuntuMemory leak in ECDSA DNSSEC verification code7.5 Highbind9UbuntuBIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate unexpectedly7.5 Highbind9UbuntuMemory leaks in code handling Diffie-Hellman key exchange via TKEY RRs (OpenSSL 3.0.0+ only)7.5 Highbind9UbuntuBuffer overread in statistics channel code5.5 Mediumbind9UbuntuProcessing large delegations may severely degrade resolver performance5.3 Mediumbind9UbuntuDestroying a TLS session early causes assertion failure7.5 Highbind9UbuntuAssertion failure on delayed DS lookup7.5 Highbind9UbuntuVersions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific...7.5 Highbind9UbuntuDoS from specifically crafted TCP packets5.3 Mediumbind9UbuntuDNS forwarders - cache poisoning vulnerability6.8 Mediumbind9UbuntuLame cache can be abused to severely degrade resolver performance5.3 Mediumbind9UbuntuA second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack8.1 Highbind9UbuntuAn assertion check can fail while answering queries for DNAME records that require the DNAME to be processed to resolve itself7.5 Highbind9UbuntuA broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly6.5 Mediumbind9UbuntuA vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack8.1 Highbind9Ubuntuupdate-policy rules of type "subdomain" are enforced incorrectly4.3 Mediumbind9UbuntuA flaw in native PKCS#11 code can lead to a remotely triggerable assertion failure in pk11.c7.5 Highbind9UbuntuA truncated TSIG response can lead to an assertion failure6.5 Mediumbind9UbuntuAttempting QNAME minimization after forwarding can lead to an assertion failure in resolver.c7.5 Highbind9UbuntuIn BIND 9.15.6 -> 9.16.5, 9.17.0 -> 9.17.3, An attacker who can establish a TCP connection with...7.5 Highbind9UbuntuA buffer boundary check assertion in rdataset.c can fail incorrectly during zone transfer4.9 Mediumbind9UbuntuA buffer boundary check assertion in rdataset.c can fail incorrectly during zone transfer4.9 Mediumbind9UbuntuA logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c7.5 Highbind9UbuntuBIND does not sufficiently limit the number of fetches performed when processing referrals8.6 Highbind9UbuntuTCP-pipelined queries can bypass tcp-clients limit7.5 Highbind9UbuntuA race condition when discarding malformed packets can cause BIND to exit with an assertion failure5.9 Mediumbind9UbuntuLimiting simultaneous TCP clients was ineffective7.5 Highbind9UbuntuZone transfer controls for writable DLZ zones were not effective5.3 Mediumbind9UbuntuAn assertion failure can occur if a trust anchor rolls over to an unsupported key algorithm when using managed-keys4.9 Mediumbind9UbuntuA specially crafted packet can cause named to leak memory7.5 Highbind9UbuntuUpdate policies krb5-subdomain and ms-subdomain do not enforce controls promised in their documentation6.5 Mediumbind9UbuntuA flaw in the "deny-answer-aliases" feature can cause an assertion failure in named7.5 Highbind9UbuntuSome versions of BIND can improperly permit recursive query service to unauthorized clients5.3 Mediumbind9UbuntuImproper fetch cleanup sequencing in the resolver can cause named to crash7.5 Highbind9Ubuntubind9 regressionNo scorebind9UbuntuAn error in TSIG authentication can permit unauthorized dynamic updates7.5 Highbind9UbuntuAn error in TSIG authentication can permit unauthorized zone transfers5.3 Mediumbind9Ubuntunamed exits with a REQUIRE assertion failure if it receives a null command string on its control channel6.5 Medium- Show moreLoading…