Skip to contentIsc vulnerabilities
Newest
- isc bind 9DNS message with invalid TSIG causes an assertion failureCVE-2025-40775Public exploitFix availableEPSS 15.4%7.5 High
- isc bind 9DNS-over-HTTPS implementation suffers from multiple issues under heavy query loadCVE-2024-12705Fix availableEPSS 18.6%7.5 High
- isc bind 9Many records in the additional section cause CPU exhaustionCVE-2024-11187Fix availableEPSS 16.1%7.5 High
- isc bind, bind 9 +1 moreAssertion failure when serving both stale cache data and authoritative zone contentCVE-2024-4076Fix available7.5 High
- isc bind, bind 9 +1 moreSIG(0) can be used to exhaust CPU resourcesCVE-2024-1975Fix available7.5 High
- isc bind, bind 9 +1 moreBIND's database will be slow if a very large number of RRs exist at the same nameCVE-2024-1737Fix available7.5 High
- isc bind, bind 9 +1 moreA flood of DNS messages over TCP may make the server unstableCVE-2024-0760Public exploitFix available7.5 High
- isc storkIncorrect TLS certificate validation can lead to escalated privilegesCVE-2024-288728.9 High
- isc bind, bind 9, netapp active iq unified manager +2 moreCleaning an ECS-enabled cache may cause excessive CPU loadCVE-2023-5680Fix available5.3 Medium
- isc bind, bind 9, netapp active iq unified manager +2 moreSpecific recursive query patterns may lead to an out-of-memory conditionCVE-2023-6516Fix available7.5 High
- isc bind, bind 9, fedoraproject fedora +1 more +3 moreEnabling both DNS64 and serve-stale may cause an assertion failure during recursive resolutionCVE-2023-5679Fix available7.5 High
- isc bind, bind 9, fedoraproject fedora +1 more +3 moreQuerying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabledCVE-2023-5517Fix available7.5 High
- debian linux, fedoraproject fedora, isc bind +5 more +7 moreThe Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is...CVE-2023-50868Public exploitFix availableEPSS 74.3%7.5 High
- fedoraproject fedora, isc bind, microsoft windows server 2008 +10 more +12 moreCertain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers...CVE-2023-50387Public exploitFix availableEPSS 100.0%7.5 High
- isc bind, bind 9, fedoraproject fedora +1 more +3 moreParsing large DNS messages may cause excessive CPU loadCVE-2023-4408Fix available7.5 High
- isc bind, bind 9, debian linux +6 more +8 morenamed may terminate unexpectedly under high DNS-over-TLS query loadCVE-2023-4236Fix available7.5 High
- isc bind, bind 9, debian linux +1 more +3 moreA stack exhaustion flaw in control channel code may cause named to terminate unexpectedlyCVE-2023-3341Fix available7.5 High
- isc bind, bind 9, netapp active iq unified manager +5 more +7 moreMalformed NSEC records can cause named to terminate unexpectedly when synth-from-dnssec is enabledCVE-2023-2829Fix available7.5 High
- isc bind, bind 9, debian linux +7 more +9 moreExceeding the recursive-clients quota may cause named to terminate unexpectedly when stale-answer-client-timeout is set to 0CVE-2023-2911Fix available7.5 High
- isc bind, bind 9, debian linux +7 more +9 morenamed's configured cache size limit can be significantly exceededCVE-2023-2828Fix available7.5 High
- isc bind, bind 9 +1 morenamed may terminate unexpectedly when processing ECS options in repeated responses to iterative queriesCVE-2022-3488EPSS 19.0%7.5 High
- isc bind, bind 9 +1 morenamed configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quotaCVE-2022-3924Fix availableEPSS 16.0%7.5 High
- isc bind, bind 9 +1 morenamed configured to answer from stale cache may terminate unexpectedly while processing RRSIG queriesCVE-2022-3736Fix availableEPSS 48.4%7.5 High
- isc bind, bind 9 +1 moreAn UPDATE message flood may cause named to exhaust all available memoryCVE-2022-3094Fix availableEPSS 13.2%7.5 High
- isc dhcp, debian linux, fedoraproject fedora +2 moreDHCP memory leakCVE-2022-2929Fix available6.5 Medium
- isc dhcp, debian linux, fedoraproject fedora +2 moreAn option refcount overflow exists in dhcpdCVE-2022-2928Fix available6.5 Medium
- debian linux, fedoraproject fedora, isc bind +2 more +4 moreMemory leaks in EdDSA DNSSEC verification codeCVE-2022-38178Fix available7.5 High
- debian linux, fedoraproject fedora, isc bind +2 more +4 moreMemory leak in ECDSA DNSSEC verification codeCVE-2022-38177Fix available7.5 High
- isc bind, fedoraproject fedora, isc bind9 +2 moreBIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate unexpectedlyCVE-2022-3080Fix available7.5 High
- isc bind, bind9 +1 moreMemory leaks in code handling Diffie-Hellman key exchange via TKEY RRs (OpenSSL 3.0.0+ only)CVE-2022-2906Fix available7.5 High
- isc bind, bind9 +1 moreBuffer overread in statistics channel codeCVE-2022-2881Fix available5.5 Medium
- debian linux, fedoraproject fedora, isc bind +1 more +3 moreProcessing large delegations may severely degrade resolver performanceCVE-2022-2795Fix available5.3 Medium
- isc bind, bind9, netapp h300s firmware +4 more +6 moreDestroying a TLS session early causes assertion failureCVE-2022-1183Fix available7.5 High
- isc bind, netapp h300e firmware, h300s firmware +6 more +8 moreAssertion failure on delayed DS lookupCVE-2022-0667Fix available7.5 High
- isc bind, netapp h300e firmware, h300s firmware +6 more +8 moreVersions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific...CVE-2022-0635Fix available7.5 High
- isc bind, fedoraproject fedora, netapp h300e firmware +8 more +10 moreDoS from specifically crafted TCP packetsCVE-2022-0396Fix available5.3 Medium
- isc bind, fedoraproject fedora, juniper junos +9 more +11 moreDNS forwarders - cache poisoning vulnerabilityCVE-2021-25220Fix available6.8 Medium
- isc bind, debian linux, fedoraproject fedora +13 more +15 moreLame cache can be abused to severely degrade resolver performanceCVE-2021-25219Fix availableEPSS 11.2%5.3 Medium
- isc bind, fedoraproject fedora, isc bind9 +2 moreA too-strict assertion check could be triggered when responses in BIND 9.16.19 and 9.17.16 require UDP fragmentation if RRL is in useCVE-2021-25218Fix available7.5 High
- isc dhcp, debian linux, fedoraproject fedora +13 more +15 moreA buffer overrun in lease file parsing code can be used to exploit a common vulnerability shared by dhcpd and dhclientCVE-2021-25217Fix available7.4 High
- isc bind, debian linux, isc bind9 +12 more +14 moreA second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attackCVE-2021-25216Fix availableEPSS 83.0%8.1 High
- isc bind, debian linux, fedoraproject fedora +14 more +16 moreAn assertion check can fail while answering queries for DNAME records that require the DNAME to be processed to resolve itselfCVE-2021-25215Fix availableEPSS 11.7%7.5 High
- isc bind, debian linux, fedoraproject fedora +13 more +15 moreA broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedlyCVE-2021-25214Fix available6.5 Medium
- isc bind, debian linux, fedoraproject fedora +5 more +7 moreA vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attackCVE-2020-8625Fix availableEPSS 65.4%8.1 High
- isc bind, canonical ubuntu linux, debian linux +4 more +6 moreupdate-policy rules of type "subdomain" are enforced incorrectlyCVE-2020-8624Fix available4.3 Medium
- isc bind, canonical ubuntu linux, debian linux +5 more +7 moreA flaw in native PKCS#11 code can lead to a remotely triggerable assertion failure in pk11.cCVE-2020-8623Fix available7.5 High
- isc bind, canonical ubuntu linux, debian linux +6 more +8 moreA truncated TSIG response can lead to an assertion failureCVE-2020-8622Fix available6.5 Medium
- isc bind, canonical ubuntu linux, isc bind9 +3 more +5 moreAttempting QNAME minimization after forwarding can lead to an assertion failure in resolver.cCVE-2020-8621Fix available7.5 High
- isc bind, canonical ubuntu linux, isc bind9 +2 more +4 moreIn BIND 9.15.6 -> 9.16.5, 9.17.0 -> 9.17.3, An attacker who can establish a TCP connection with...CVE-2020-8620Fix available7.5 High
- isc bind, bind9, canonical ubuntu linux +4 more +6 moreA buffer boundary check assertion in rdataset.c can fail incorrectly during zone transferCVE-2020-8619Fix available4.9 Medium
- Show moreLoading…