Skip to contentPowerdns vulnerabilities
Newest
- powerdns dnsdistHTML injection in the web dashboardCVE-2026-0396Fix available3.1 Low
- powerdns recursorCrafted zones can lead to increased incoming network trafficCVE-2026-24027Fix available5.3 Medium
- powerdns recursorCrafted zones can lead to increased resource usage and crafted CNAME chains can lead to cache poisoning in RecursorCVE-2026-0398Fix available5.3 Medium
- powerdns recursorInternal logic flaw in cache management can lead to a denial of service in PowerDNS RecursorCVE-2025-59029Fix available5.3 Medium
- powerdns recursorInsufficient validation of incoming notifies over TCP can lead to a denial of service in RecursorCVE-2025-59030Fix available7.5 High
- powerdns recursorCrafted delegations or IP fragments can poison cached delegations in RecursorCVE-2025-59024Fix available6.5 Medium
- powerdns recursorCrafted delegations or IP fragments can poison cached delegations in RecursorCVE-2025-59023Fix available8.2 High
- powerdns dnsdistDenial of service via crafted DoH exchange in PowerDNS DNSdistCVE-2025-30187Fix available3.7 Low
- powerdns recursorA Recursor configured to send out ECS enabled queries can be sensitive to spoofing attemptsCVE-2025-30192Fix available7.5 High
- powerdns dnsdistDenial of service via crafted TCP exchangeCVE-2025-30193Fix available7.5 High
- powerdns dnsdistDenial of service via crafted DoH exchangeCVE-2025-30194Fix available7.5 High
- powerdns recursorA crafted zone can lead to an illegal memory access in the PowerDNS RecursorCVE-2025-30195Fix available7.5 High
- powerdns recursorCrafted responses can lead to a denial of service due to cache inefficiencies in the RecursorCVE-2024-25590Fix available7.5 High
- powerdns dnsdistTransfer requests received over DoH can lead to a denial of service in DNSdistCVE-2024-25581Fix available7.5 High
- powerdns recursor, powerdns +1 moreCrafted responses can lead to a denial of service in Recursor if recursive forwarding is configuredCVE-2024-25583Fix available7.5 High
- debian linux, fedoraproject fedora, isc bind +5 more +7 moreThe Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is...CVE-2023-50868Public exploitFix availableEPSS 74.3%7.5 High
- fedoraproject fedora, isc bind, microsoft windows server 2008 +10 more +12 moreCertain DNSSEC aspects of the DNS protocol (in RFC 4035 and related RFCs) allow remote attackers...CVE-2023-50387Public exploitFix availableEPSS 100.0%7.5 High
- powerdns recursorDeterred spoofing attempts can lead to authoritative servers being marked unavailableCVE-2023-26437Fix available3.4 Low
- powerdns recursorA remote attacker might be able to cause infinite recursion in PowerDNS Recursor 4.8.0 via a DNS...CVE-2023-22617Fix available7.5 High
- powerdns recursor, fedoraproject fedora +1 morePowerDNS Recursor up to and including 4.5.9, 4.6.2 and 4.7.1, when protobuf logging is enabled,...CVE-2022-37428Fix available6.5 Medium
- powerdns authoritative server, recursor, fedoraproject fedora +2 moreIn PowerDNS Authoritative Server before 4.4.3, 4.5.x before 4.5.4, and 4.6.x before 4.6.1 and...CVE-2022-27227Fix available7.5 High
- powerdns authoritative serverPowerDNS Authoritative Server 4.5.0 before 4.5.1 allows anybody to crash the process by sending a...CVE-2021-36754Fix availableEPSS 64.9%7.5 High
- powerdns recursor, opensuse backports sle, leap +2 moreAn issue has been found in PowerDNS Recursor before 4.1.18, 4.2.x before 4.2.5, and 4.3.x before...CVE-2020-25829Fix available7.5 High
- powerdns authoritativeAn issue was discovered in PowerDNS Authoritative through 4.3.0 when --enable-experimental-gss...CVE-2020-24698Fix available9.8 Critical
- powerdns authoritativeAn issue was discovered in PowerDNS Authoritative through 4.3.0 when --enable-experimental-gss...CVE-2020-24697Fix available7.5 High
- powerdns authoritativeAn issue was discovered in PowerDNS Authoritative through 4.3.0 when --enable-experimental-gss...CVE-2020-24696Fix available8.1 High
- powerdns authoritativeAn issue has been found in PowerDNS Authoritative Server before 4.3.1 where an authorized user...CVE-2020-17482Fix available4.3 Medium
- powerdns recursorIn PowerDNS Recursor versions up to and including 4.3.1, 4.2.2 and 4.1.16, the ACL restricting...CVE-2020-14196Fix available5.3 Medium
- powerdns recursor, debian linux, fedoraproject fedora +2 more +4 moreAn issue has been found in PowerDNS Recursor 4.1.0 through 4.3.0 where records in the answer...CVE-2020-12244Fix available7.5 High
- powerdns recursor, debian linux, fedoraproject fedora +2 more +4 morePowerDNS Recursor from 4.1.0 up to and including 4.3.0 does not sufficiently defend against...CVE-2020-10995Fix available7.5 High
- powerdns recursorAn issue has been found in PowerDNS Recursor 4.1.0 up to and including 4.3.0. It allows an...CVE-2020-10030Fix availableEPSS 24.5%8.8 High
- debian pdns, powerdns authoritative server +1 morePowerDNS Authoritative daemon , all versions pdns 4.1.x before pdns 4.1.10, exiting when...CVE-2019-10203Fix available4.3 Medium
- powerdns authoritative, debian pdns, opensuse backports +1 more +3 moreA Vulnerability has been found in PowerDNS Authoritative Server before versions 4.1.9, 4.0.8...CVE-2019-10163Fix available3.5 Low
- powerdns authoritative, debian pdns, opensuse leap +2 moreA vulnerability has been found in PowerDNS Authoritative Server before versions 4.1.10, 4.0.8...CVE-2019-10162Fix available3.5 Low
- powerdns authoritative server, debian pdns, fedoraproject fedora +2 moreA vulnerability was found in PowerDNS Authoritative Server before 4.0.7 and before 4.1.7. An...CVE-2019-3871Fix availableEPSS 12.6%6.5 Medium
- powerdns recursor, power dns pdns-recursor +1 moreAn issue has been found in PowerDNS Recursor versions 4.1.x before 4.1.9 where records in the...CVE-2019-3807Fix available3.7 Low
- powerdns recursor, power dns pdns-recursor +1 moreAn issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks...CVE-2019-3806Fix available5.4 Medium
- powerdns recursor, [unknown] pdns-recursor +1 moreAn issue has been found in PowerDNS Recursor before version 4.1.8 where a remote attacker sending...CVE-2018-16855Fix availableEPSS 58.6%7.5 High
- powerdns authoritative, recursor, debian pdns +1 more +3 morePowerDNS Authoritative Server 4.1.0 up to 4.1.4 inclusive and PowerDNS Recursor 4.0.0 up to 4.1.4...CVE-2018-14626Fix available5.3 Medium
- powerdns authoritative, recursor, debian pdns +1 more +3 morePowerDNS Authoritative Server 3.3.0 up to 4.1.4 excluding 4.1.5 and 4.0.6, and PowerDNS Recursor...CVE-2018-10851Fix available5.3 Medium
- [unknown] dnsdistAn issue has been found in PowerDNS DNSDist before 1.3.3 allowing a remote attacker to craft a...CVE-2018-14663Fix available5.9 Medium
- powerdns recursor, [unknown] pdns +1 moreAn issue has been found in PowerDNS Recursor from 4.0.0 up to and including 4.1.4. A remote...CVE-2018-14644Fix available5.3 Medium
- open-xchange dnsdistAn issue has been found in dnsdist before 1.2.0 in the way EDNS0 OPT records are handled when...CVE-2016-7069Fix available5.9 Medium
- [unknown] pdnspdns before version 4.1.2 is vulnerable to a buffer overflow in dnsreplay. In the dnsreplay tool...CVE-2018-1046Fix available7.0 High
- powerdns recursorAn issue has been found in the DNSSEC parsing code of PowerDNS Recursor from 4.0.0 up to and...CVE-2017-15094Fix available5.9 Medium
- powerdns recursorWhen api-config-dir is set to a non-empty value, which is not the case by default, the API in...CVE-2017-15093Fix available5.3 Medium
- powerdns recursorA cross-site scripting issue has been found in the web interface of PowerDNS Recursor from 4.0.0...CVE-2017-15092Fix available6.1 Medium
- powerdns authoritativeAn issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4...CVE-2017-15091Fix available7.1 High
- powerdns, powerdns recursor +1 moreAn issue has been found in the DNSSEC validation component of PowerDNS Recursor from 4.0.0 and up...CVE-2017-15090Fix available5.9 Medium
- powerdns recursorImproper input validation bugs in DNSSEC validators components in PowerDNS version 4.1.0 allow...CVE-2018-1000003Fix available3.7 Low
- Show moreLoading…