Every CVE Search/ Get API key

CVE-2019-3806

An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks...

5.4 MediumFix available

An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks are not properly applied to queries received over TCP in some specific combination of settings, possibly bypassing security policies enforced using Lua.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
High

Exploit likelihood

1.45%Up 0.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 5.4

An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks are not properly applied to queries received over TCP in some specific combination of settings, possibly bypassing security policies enforced using Lua.

Record
CVE-2019-3806
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
Weakness
CWE-358
Updated
2026-11-02
EUVDEUVD-2019-13432 5.4

An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks are not properly applied to queries received over TCP in some specific combination of settings, possibly bypassing security policies enforced using Lua.

Record
EUVD-2019-13432
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-3jqp-f4vw-9c87 8.1

An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks...

An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks are not properly applied to queries received over TCP in some specific combination of settings, possibly bypassing security policies enforced using Lua.

Record
GHSA-3jqp-f4vw-9c87
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
NVD 8.1

An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks are not properly applied to queries received over TCP in some specific combination of settings, possibly bypassing security policies enforced using Lua.

Record
CVE-2019-3806
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-358
Updated
2026-11-02
OSVALPINE-CVE-2019-3806 8.1

An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks are not properly applied to queries received over TCP in some specific combination of settings, possibly bypassing security policies enforced using Lua.

Record
ALPINE-CVE-2019-3806
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.1

An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks are not properly applied to queries received over TCP in some specific combination of settings, possibly bypassing security policies enforced using Lua.

Record
CVE-2019-3806
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2019-3806 8.1

An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks are not properly applied to queries received over TCP in some specific combination of settings, possibly bypassing security policies enforced using Lua.

Record
DEBIAN-CVE-2019-3806
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-3806 8.1

An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks are not properly applied to queries received over TCP in some specific combination of settings, possibly bypassing security policies enforced using Lua.

Record
UBUNTU-CVE-2019-3806
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
Updated
2026-11-02
OSVMGASA-2019-0051 No score

Updated pdns-recursor package fixes security vulnerabilities

An issue has been found in PowerDNS Recursor where Lua hooks are not properly applied to queries received over TCP in some specific combination of settings, possibly bypassing security policies enforced using Lua (CVE-2019-3806).

An issue has been found in PowerDNS Recursor where records in the answer section of responses received from authoritative servers with the AA flag not set were not properly validated, allowing an attacker to bypass DNSSEC validation (CVE-2019-3807).

Record
MGASA-2019-0051
Updated
2026-11-02
OSVopenSUSE-SU-2019:0131-1 No score

Security update for pdns-recursor

This update for pdns-recursor to version 4.1.10 fixes the following issues:

Security issues fixed:

  • CVE-2019-3806: Fixed a case when Lua hooks are not called over TCP (boo#1121887)
  • CVE-2019-3807: Fixed an issue where DNSSEC validation was not performed for AA=0 responses (boo#1121889)
Record
openSUSE-SU-2019:0131-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11157-1 No score

pdns-recursor-4.5.5-1.3 on GA media

These are all security issues fixed in the pdns-recursor-4.5.5-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11157-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pdns-recursor
Alpine:v3.10
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.11
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.12
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.13
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.14
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.15
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.16
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.17
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.18
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.19
before 4.1.9-r0
4.1.9-r0
Show 15 moreShow less
Affected packages
PackageAffectedFixed
pdns-recursor
Alpine:v3.20
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.21
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.22
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.23
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.24
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.8
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Alpine:v3.9
before 4.1.9-r0
4.1.9-r0
pdns-recursor
Debian:12
before 4.1.9-1
4.1.9-1
pdns-recursor
Debian:13
before 4.1.9-1
4.1.9-1
pdns-recursor
Debian:14
before 4.1.9-1
4.1.9-1
pdns-recursor
Mageia:6
before 4.1.9-1.mga6
4.1.9-1.mga6
pdns-recursor
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.7.3-14.0.0~alpha1-14.0.0~alpha1-24.0.0~alpha2-24.0.0~alpha2-2ubuntu0.14.0.0~alpha2-2ubuntu0.1+esm1
None known
pdns-recursor
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
4.0.6-14.0.6-1build14.0.7-14.1.1-14.1.1-1build14.1.1-24.1.1-2ubuntu0.1~esm1
None known
pdns-recursor
SUSE:Package Hub 12 SP1
before 4.1.10-16.1
4.1.10-16.1
pdns-recursor
openSUSE:Tumbleweed
before 4.5.5-1.3
4.5.5-1.3

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-3806 is a medium vulnerability (CVSS 5.4) in Powerdns Recursor, published January 23, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.45%, the 73rd percentile. Fixed in pdns-recursor 4.1.9-r0.

References

Show 26 moreShow less
MoveEnter Open