Every CVE Search/ Get API key

CVE-2026-44690

Cross-zone wildcard cache poisoning via RRSIG.labels manipulation

7.5 HighFix available

CVE-2026-44690 is a high vulnerability (CVSS 7.5) in Nlnet Labs Unbound, published July 22, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.15%, the 4th percentile. Fixed in unbound 1.25.2-r0.

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

0.15%Unchanged since Jul 23, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.5

Cross-zone wildcard cache poisoning via RRSIG.labels manipulation

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.

Record
CVE-2026-44690
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-345
Updated
2026-11-02
EUVDEUVD-2026-47669 7.5

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.

Record
EUVD-2026-47669
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-jwg4-375h-655h 7.5

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG...

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.

Record
GHSA-jwg4-375h-655h
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-345
Updated
2026-11-02
NVD 7.5

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.

Record
CVE-2026-44690
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-345
Updated
2026-11-02
OSVALPINE-CVE-2026-44690 7.5

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.

Record
ALPINE-CVE-2026-44690
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSV 7.5

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.

Record
CVE-2026-44690
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
Show 34 moreShow less
OSVDEBIAN-CVE-2026-44690 7.5

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.

Record
DEBIAN-CVE-2026-44690
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVOESA-2026-3333 7.5

unbound security update

Unbound is a validating, recursive, caching DNS resolver. It is designed to be fast and lean and incorporates modern features based on open standards. To help increase online privacy, Unbound supports DNS-over-TLS which allows clients to encrypt their communication. Unbound is available for most platforms such as FreeBSD, OpenBSD, NetBSD, MacOS, Linux and Microsoft Windows. Unbound is a totally free, open source software under the BSD license. It doesn't make custom builds or provide specific features to paying customers only.

Security Fix(es):

With NLnet Labs Unbound up to and including version 1.25.1, applications using libunbound and configured with 'unwanted-reply-threshold', could eventually be abruptly terminated if the threshold is reached and libunbound needs to call 'libworker_alloc_cleanup' since the function is absent from the function call allow list. When an application using libunbound sets 'unwanted-reply-threshold' to any non-zero value and the iterator queries an authoritative that replies with enough wrong-transaction-ID UDP datagrams to cross the threshold, the 'libworker_alloc_cleanup' will eventually be called. Since the function is absent from the function call allow list, this leads to a fatal exit of libunbound and eventual termination of the embedding application.Unbound itself is not affected since its relevant function 'worker_alloc_cleanup' is registed in the allow list and proceeds to perform the documented cache flush.(CVE-2026-44621)

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.(CVE-2026-44690)

In NLnet Labs Unbound 1.6.0 up to and including 1.25.1, a replay of a wildcard rrset as another piece of data, could be briefly considered DNSSEC secure based only on the RRSIG validation and stored into cache, before later validation treats it as bogus based on NSEC validation. When the resolving thread puts secure on the rrset, and another thread that is on the serve expired path then picks up the updated rrset contents with the secure status for a reply, it can be used to change a specific record, next to a wildcard that could be covered by the wildcard, into the wildcard. A malicious actor can exploit the possible poisonous effect by having any DNSSEC-singed domain (irrelevant to the victim domain) and a CNAME wrapper record that points to a record next to a wildcard (that could be covered by the wildcard). Then quering Unbound for the wildcard sibling record would seed the secure message. A later (after expiry) query for the CNAME wrapper would need to resolve the target sibling record. If the wildcard replay is injected into the response, the wildcard rrset will update the expired sibling record with a secure status before completing proper wildcard validation with NSEC records and eventually treating the CNAME wrapper answer as bogus. The updated poisoned rrset is now secure and points to the wildcard. This vulnerability is explicit for the serve expired path and needs injection of the signed wildcard rrset without the NSEC accompanying rrset.(CVE-2026-46582)

In NLnet Labs Unbound 1.6.2 up to and including 1.25.1,…

Record
OESA-2026-3333
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVOESA-2026-3334 7.5

unbound security update

Unbound is a validating, recursive, caching DNS resolver. It is designed to be fast and lean and incorporates modern features based on open standards. To help increase online privacy, Unbound supports DNS-over-TLS which allows clients to encrypt their communication. Unbound is available for most platforms such as FreeBSD, OpenBSD, NetBSD, MacOS, Linux and Microsoft Windows. Unbound is a totally free, open source software under the BSD license. It doesn't make custom builds or provide specific features to paying customers only.

Security Fix(es):

In Unbound 1.9.0 up to and including 1.25.1, when a DNSCrypt query is received over TCP, the routine that encrypts the reply in place fails to bound the reply length against the destination buffer size. The size clamp that protects the UDP path is not applied on the TCP path, so a reply larger than 65504 bytes is shifted forward by 48 bytes inside a buffer of capacity equal to 'msg-buffer-size', writing past the end of the heap allocation. A single malicious encrypted query crashes the resolver and lead to denial of service. This vulnerability needs Unbound to be compiled with DNSCrypt support ('--enable-dnscrypt') and the 'dnscrypt:' clause to be configured and enabled for the listening interfaces.(CVE-2026-40691)

With NLnet Labs Unbound up to and including version 1.25.1, applications using libunbound and configured with 'unwanted-reply-threshold', could eventually be abruptly terminated if the threshold is reached and libunbound needs to call 'libworker_alloc_cleanup' since the function is absent from the function call allow list. When an application using libunbound sets 'unwanted-reply-threshold' to any non-zero value and the iterator queries an authoritative that replies with enough wrong-transaction-ID UDP datagrams to cross the threshold, the 'libworker_alloc_cleanup' will eventually be called. Since the function is absent from the function call allow list, this leads to a fatal exit of libunbound and eventual termination of the embedding application.Unbound itself is not affected since its relevant function 'worker_alloc_cleanup' is registed in the allow list and proceeds to perform the documented cache flush.(CVE-2026-44621)

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.(CVE-2026-44690)

In NLnet Labs Unbound 1.6.0 up to and including 1.25.1, a replay of a wildcard rrset as another piece of data, could be briefly considered DNSSEC secure based only on the RRSIG validation and stored into cache, before later validation treats it as bogus based on NSEC validation. When the resolving thread puts secure on the rrset, and another thread that is on the serve expired path then picks up the updated rrset contents with the secure status for a reply, it can be used to change a specific record, next to a wildcard that could be covered by the wildcard, into the wildcard. A malicious actor can exploit the possible poisonous effect by having any DNSSEC-singed domain (irrelevant to the victim domain) and a CNAME wrapper record that points to a record next to a wildcard (that could…

Record
OESA-2026-3334
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVOESA-2026-3335 7.5

unbound security update

Unbound is a validating, recursive, caching DNS resolver. It is designed to be fast and lean and incorporates modern features based on open standards. To help increase online privacy, Unbound supports DNS-over-TLS which allows clients to encrypt their communication. Unbound is available for most platforms such as FreeBSD, OpenBSD, NetBSD, MacOS, Linux and Microsoft Windows. Unbound is a totally free, open source software under the BSD license. It doesn't make custom builds or provide specific features to paying customers only.

Security Fix(es):

In Unbound 1.9.0 up to and including 1.25.1, when a DNSCrypt query is received over TCP, the routine that encrypts the reply in place fails to bound the reply length against the destination buffer size. The size clamp that protects the UDP path is not applied on the TCP path, so a reply larger than 65504 bytes is shifted forward by 48 bytes inside a buffer of capacity equal to 'msg-buffer-size', writing past the end of the heap allocation. A single malicious encrypted query crashes the resolver and lead to denial of service. This vulnerability needs Unbound to be compiled with DNSCrypt support ('--enable-dnscrypt') and the 'dnscrypt:' clause to be configured and enabled for the listening interfaces.(CVE-2026-40691)

With NLnet Labs Unbound up to and including version 1.25.1, applications using libunbound and configured with 'unwanted-reply-threshold', could eventually be abruptly terminated if the threshold is reached and libunbound needs to call 'libworker_alloc_cleanup' since the function is absent from the function call allow list. When an application using libunbound sets 'unwanted-reply-threshold' to any non-zero value and the iterator queries an authoritative that replies with enough wrong-transaction-ID UDP datagrams to cross the threshold, the 'libworker_alloc_cleanup' will eventually be called. Since the function is absent from the function call allow list, this leads to a fatal exit of libunbound and eventual termination of the embedding application.Unbound itself is not affected since its relevant function 'worker_alloc_cleanup' is registed in the allow list and proceeds to perform the documented cache flush.(CVE-2026-44621)

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.(CVE-2026-44690)

In NLnet Labs Unbound 1.6.0 up to and including 1.25.1, a replay of a wildcard rrset as another piece of data, could be briefly considered DNSSEC secure based only on the RRSIG validation and stored into cache, before later validation treats it as bogus based on NSEC validation. When the resolving thread puts secure on the rrset, and another thread that is on the serve expired path then picks up the updated rrset contents with the secure status for a reply, it can be used to change a specific record, next to a wildcard that could be covered by the wildcard, into the wildcard. A malicious actor can exploit the possible poisonous effect by having any DNSSEC-singed domain (irrelevant to the victim domain) and a CNAME wrapper record that points to a record next to a wildcard (that could…

Record
OESA-2026-3335
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVOESA-2026-3336 7.5

unbound security update

Unbound is a validating, recursive, caching DNS resolver. It is designed to be fast and lean and incorporates modern features based on open standards. To help increase online privacy, Unbound supports DNS-over-TLS which allows clients to encrypt their communication. Unbound is available for most platforms such as FreeBSD, OpenBSD, NetBSD, MacOS, Linux and Microsoft Windows. Unbound is a totally free, open source software under the BSD license. It doesn't make custom builds or provide specific features to paying customers only.

Security Fix(es):

With NLnet Labs Unbound up to and including version 1.25.1, applications using libunbound and configured with 'unwanted-reply-threshold', could eventually be abruptly terminated if the threshold is reached and libunbound needs to call 'libworker_alloc_cleanup' since the function is absent from the function call allow list. When an application using libunbound sets 'unwanted-reply-threshold' to any non-zero value and the iterator queries an authoritative that replies with enough wrong-transaction-ID UDP datagrams to cross the threshold, the 'libworker_alloc_cleanup' will eventually be called. Since the function is absent from the function call allow list, this leads to a fatal exit of libunbound and eventual termination of the embedding application.Unbound itself is not affected since its relevant function 'worker_alloc_cleanup' is registed in the allow list and proceeds to perform the documented cache flush.(CVE-2026-44621)

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.(CVE-2026-44690)

In NLnet Labs Unbound 1.6.0 up to and including 1.25.1, a replay of a wildcard rrset as another piece of data, could be briefly considered DNSSEC secure based only on the RRSIG validation and stored into cache, before later validation treats it as bogus based on NSEC validation. When the resolving thread puts secure on the rrset, and another thread that is on the serve expired path then picks up the updated rrset contents with the secure status for a reply, it can be used to change a specific record, next to a wildcard that could be covered by the wildcard, into the wildcard. A malicious actor can exploit the possible poisonous effect by having any DNSSEC-singed domain (irrelevant to the victim domain) and a CNAME wrapper record that points to a record next to a wildcard (that could be covered by the wildcard). Then quering Unbound for the wildcard sibling record would seed the secure message. A later (after expiry) query for the CNAME wrapper would need to resolve the target sibling record. If the wildcard replay is injected into the response, the wildcard rrset will update the expired sibling record with a secure status before completing proper wildcard validation with NSEC records and eventually treating the CNAME wrapper answer as bogus. The updated poisoned rrset is now secure and points to the wildcard. This vulnerability is explicit for the serve expired path and needs injection of the signed wildcard rrset without the NSEC accompanying rrset.(CVE-2026-46582)

In NLnet Labs Unbound 1.6.2 up to and including 1.25.1,…

Record
OESA-2026-3336
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVOESA-2026-3436 7.5

unbound security update

Unbound is a validating, recursive, caching DNS resolver. It is designed to be fast and lean and incorporates modern features based on open standards. To help increase online privacy, Unbound supports DNS-over-TLS which allows clients to encrypt their communication. Unbound is available for most platforms such as FreeBSD, OpenBSD, NetBSD, MacOS, Linux and Microsoft Windows. Unbound is a totally free, open source software under the BSD license. It doesn't make custom builds or provide specific features to paying customers only.

Security Fix(es):

In Unbound 1.9.0 up to and including 1.25.1, when a DNSCrypt query is received over TCP, the routine that encrypts the reply in place fails to bound the reply length against the destination buffer size. The size clamp that protects the UDP path is not applied on the TCP path, so a reply larger than 65504 bytes is shifted forward by 48 bytes inside a buffer of capacity equal to 'msg-buffer-size', writing past the end of the heap allocation. A single malicious encrypted query crashes the resolver and lead to denial of service. This vulnerability needs Unbound to be compiled with DNSCrypt support ('--enable-dnscrypt') and the 'dnscrypt:' clause to be configured and enabled for the listening interfaces.(CVE-2026-40691)

In NLnet Labs Unbound 1.16.2 up to and including 1.25.1, a similar vulnerability as with CVE-2026-40622 in the 'ghost domain names' family of attacks was found in Unbound that could extend the ghost domain window by up to one cached TTL configured value for A/AAAA glue records. Similar to other 'ghost domain names' attacks, an adversary needs to control a (ghost) zone and be able to query a vulnerable Unbound. A single client A/AAAA query can cause Unbound to overwrite the cached expired parent-side glue rrset and essentially extend the ghost domain window by up to one cached TTL configured value ('cache-max-ttl'). In configurations where 'harden-referral-path: yes' is used (non-default configuration), no client query is required since Unbound implicitly performs that query. This is a variant of CVE-2026-40622 which only addressed the NS query.(CVE-2026-42955)

With NLnet Labs Unbound up to and including version 1.25.1, applications using libunbound and configured with 'unwanted-reply-threshold', could eventually be abruptly terminated if the threshold is reached and libunbound needs to call 'libworker_alloc_cleanup' since the function is absent from the function call allow list. When an application using libunbound sets 'unwanted-reply-threshold' to any non-zero value and the iterator queries an authoritative that replies with enough wrong-transaction-ID UDP datagrams to cross the threshold, the 'libworker_alloc_cleanup' will eventually be called. Since the function is absent from the function call allow list, this leads to a fatal exit of libunbound and eventual termination of the embedding application.Unbound itself is not affected since its relevant function 'worker_alloc_cleanup' is registed in the allow list and proceeds to perform the documented cache flush.(CVE-2026-44621)

In NLnet Labs Unbound 1.13.2 up to and including 1.25.1, stub or forward zones where the name is below an intermediate labed below a DNSSEC signed zone could be shadowed by the intermediate label's secure NXDOMAIN answer from the parent. This is caused by an off-by-one error in 'harden-below-nxdomain' logic; enabled by default. It effectively bypasses the configuration and the configured stub/forward zone is never contacted. 'harden-below-nxdomain' does an upward DNS cache walk together with a delegation point guard that does not allow NXDOMAIN synthesis above stub/forward zones. The guard tests the domain name but before stripping a label. This results in an iteration where the domain name equals the configured stub/forward zone apex that…

Record
OESA-2026-3436
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVRHSA-2026:43588 8.6

Red Hat Security Advisory: Red Hat Hardened Images RPMs bug fix and enhancement update

Record
RHSA-2026:43588
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVRHSA-2026:55784 8.6

Red Hat Security Advisory: unbound security update

Record
RHSA-2026:55784
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVRHSA-2026:55841 8.6

Red Hat Security Advisory: unbound security update

Record
RHSA-2026:55841
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVRHSA-2026:55892 8.6

Red Hat Security Advisory: unbound security update

Record
RHSA-2026:55892
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVRLSA-2026:55784 8.6

Important: unbound security update

The unbound packages provide a validating, recursive, and caching DNS or DNSSEC resolver.

Security Fix(es):

  • unbound: Unbound: Cache poisoning via insufficient RRSIG.Labels validation and premature cache writes (CVE-2026-44690)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Record
RLSA-2026:55784
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVRLSA-2026:55841 8.6

Important: unbound security update

The unbound packages provide a validating, recursive, and caching DNS or DNSSEC resolver.

Security Fix(es):

  • unbound: Unbound: Cache poisoning via insufficient RRSIG.Labels validation and premature cache writes (CVE-2026-44690)

  • unbound: Unbound: Denial of Service via malformed EDNS Report-Channel option (CVE-2026-55973)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Record
RLSA-2026:55841
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVRLSA-2026:55892 8.6

Important: unbound security update

The unbound packages provide a validating, recursive, and caching DNS or DNSSEC resolver.

Security Fix(es):

  • unbound: Unbound: Cache poisoning via insufficient RRSIG.Labels validation and premature cache writes (CVE-2026-44690)

  • unbound: Unbound: Denial of Service via malformed EDNS Report-Channel option (CVE-2026-55973)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Record
RLSA-2026:55892
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2026-44690 7.5

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.

Record
UBUNTU-CVE-2026-44690
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVALSA-2026:55784 No score

Important: unbound security update

The unbound packages provide a validating, recursive, and caching DNS or DNSSEC resolver.

Security Fix(es):

  • unbound: Unbound: Cache poisoning via insufficient RRSIG.Labels validation and premature cache writes (CVE-2026-44690)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Record
ALSA-2026:55784
Updated
2026-11-02
OSVALSA-2026:55841 No score

Important: unbound security update

The unbound packages provide a validating, recursive, and caching DNS or DNSSEC resolver.

Security Fix(es):

  • unbound: Unbound: Cache poisoning via insufficient RRSIG.Labels validation and premature cache writes (CVE-2026-44690)
  • unbound: Unbound: Denial of Service via malformed EDNS Report-Channel option (CVE-2026-55973)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Record
ALSA-2026:55841
Updated
2026-11-02
OSVALSA-2026:55892 No score

Important: unbound security update

The unbound packages provide a validating, recursive, and caching DNS or DNSSEC resolver.

Security Fix(es):

  • unbound: Unbound: Cache poisoning via insufficient RRSIG.Labels validation and premature cache writes (CVE-2026-44690)
  • unbound: Unbound: Denial of Service via malformed EDNS Report-Channel option (CVE-2026-55973)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Record
ALSA-2026:55892
Updated
2026-11-02
OSVAZL-92931 No score

CVE-2026-44690 affecting package unbound for versions less than 1.25.2-1

In NLnet Labs Unbound 1.7.0 up to and including 1.25.1, insufficient validation of the RRSIG.Labels field combined with premature cache writes during RFC 8198 aggressive NSEC processing leads to cache poisoning that permits a malicious actor controlling a single delegated zone to poison arbitrary sibling zones under NSEC-signed parent domains. A malicious actor with one registered domain under an NSEC-signed TLD can serve malicious insecure DNS responses for unrelated sibling domains (sharing the same parent zone). Arbitrary delegations that do not exist under the parent domain and are covered by the parent's NSEC chain can be brought into insecure existence by fraudulent wildcard DS records (less labels than expected, unknown algorithm) from the malicious sibling domain. This allows the malicious actor to inject insecure wildcard records for those delegations.

Record
AZL-92931
Updated
2026-11-02
OSVCLSA-2026-1785490706 No score

unbound: Fix of 3 CVEs

  • CVE-2024-43167: guard against a NULL forward-zone name in ub_ctx_set_fwd to prevent a NULL pointer dereference
  • CVE-2026-44690: reject RRSIG label counts below the signer label count and restrict wildcard rrset cache updates to the signer authority, deferring the cache write until the proof succeeds
  • CVE-2026-56416: bound the second domain name in canonicalized RDATA and reject multi-dname RRs whose rdata ends early, preventing a heap buffer overflow
Record
CLSA-2026-1785490706
Updated
2026-11-02
OSVMGASA-2026-0316 No score

Updated unbound packages fix security vulnerabilities

Unbound packages updated to version 1.25.2 which incorporates a number of security and bug fixes.

Record
MGASA-2026-0316
Updated
2026-11-02
OSVMGASA-2026-0451 No score

Updated unbound packages fixes security vulnerabilities

Heap buffer overflow and possible Remote Code Execution when digesting DNSKEY Possible heap buffer overflow during DNSSEC canonicalization CNAME synthesis could lead to heap corruption Possible ZONEMD verification bypass window Use-after-free in DoQ stream output buffer on reset re-transmission Possible degradation of service from continuous queries on the same TCP/DoT connection Use-after-free in DoH stream cleanup code path Retrap: Novel Vulnerabilities to launch Algorithmic Complexity Attacks on DNSSEC 'serve-expired' can bypass Unbound 'wait-limit' Remote DNS-over-QUIC denial of service due to 'quic-size' budget bypass Packet of death for DNSCrypt over TCP Cross-zone wildcard cache poisoning via RRSIG.labels manipulation 'dns-error-reporting: yes' leads to stack buffer overflow Assertion in libngtcp2 when under pressure in high concurrency DNS-over-QUIC environments Libunbound applications configured with 'unwanted-reply-threshold' could eventually be abruptly terminated 'max-global-quota' reset by DNSSEC validation restarts Possible heap use-after-free in an error path when a DoT forwarded query is jostled out 'response-ip'/'rpz' can rewrite BOGUS answers instead of returning SERVFAIL BOGUS configured primary hostname accepted for XFR in auth/rpz zones Date: Attacker supplied '0.0.0.0'/'::' glue triggers defensive full-cache flush Possible cache poisoning attack by mapping source port population per thread Memory corruption could lead to crash and denial of service 'serve-expired-client-timeout' and 'response-ip' CNAME redirect could lead to a crash Packet of death for a DNSCrypt misconfigured Unbound Remote DNS-over-QUIC (DoQ) flow-control assertion failure in libngtcp2 Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name Degradation of resolution service when 'discard-timeout' and 'serve-expired-client-timeout' are combined in unusual configuration Degradation of resolution service from improperly accounted client-terminated DNS-over-QUIC queries Extra fix for CVE-2026-40622 to also clamp the TTL of A/AAAA records disallowing a one-time 'ghost domain' delegation renewal via glue records Off-by-one error in 'harden-below-nxdomain' logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN A wildcard replay, as another piece of data, triggers poisoning in the serve expired reply path DNS Cookie bypass when combined with proxy-protocol use Privacy/configuration issue when adding local data in views through 'unbound-control' Possible arbitrary code execution during DNSSEC validation Heap overflow with multiple NSID, COOKIE, PADDING EDNS options Crash during DNSSEC validation of malicious content Date: Packet of death with DNSCrypt Another "ghost domain names" attack variant Long list of incoming EDNS options degrades performance Jostle logic bypass degrades resolution performance Degradation of service with unbounded NSEC3 hash calculations Possible cache poisoning via promiscuous records for the authority section Unbounded name compression in certain cases causes degradation of service Use after free and crash under special conditions in RPZ code Possible domain hijacking via promiscuous records in the authority section Cache poisoning via the ECS-enabled Rebirthday Attack Unbounded name compression could lead to Denial of Service Unbound vulnerable to the "DNSBomb" pulsing DoS amplification attack Denial of service when trimming EDE text on positive replies DNSSEC verification complexity can be exploited to exhaust CPU resources and stall DNS resolvers NSEC3 closest encloser proof can exhaust CPU Non-Responsive Delegation Attack Novel "ghost domain names" attack by updating almost expired delegation information Novel "ghost domain names" attack by introducing subdomain delegations Local symlink attack Vulnerability in Domain Parse NXNSAttack Vulnerability in IPSEC module Vulnerability in parsing NOTIFY queries Vulnerability in the processing of wildcard synthesized NSEC…

Record
MGASA-2026-0451
Updated
2026-11-02
OSVopenSUSE-SU-2026:11380-1 No score

libunbound8-1.25.2-1.1 on GA media

These are all security issues fixed in the libunbound8-1.25.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:11380-1
Updated
2026-11-02
OSVopenSUSE-SU-2026:21550-1 No score

Security update for unbound

This update for unbound fixes the following issues:

Update to version 1.25.2.

Security issues fixed:

  • CVE-2026-14586: DoS via assertion in libngtcp2 for DNS-over-QUIC environments with high concurrency (bsc#1271879).
  • CVE-2026-32665: Remote DNS-over-QUIC denial of service due to quic-size budget bypass (bsc#1271873).
  • CVE-2026-40691: DoS due to heap overflow via single bad DNSCrypt query over TCP (bsc#1271875).
  • CVE-2026-41637: Degradation of resolution service due to improperly accounted client-terminated DNS-over-QUIC queries (bsc#1271891).
  • CVE-2026-42955: Ghost domain window can be extended by up to one cached TTL configured value for A/AAAA glue records (bsc#1271892).
  • CVE-2026-44621: Libunbound applications configured with unwanted-reply-threshold could eventually be abruptly terminated (bsc#1271876).
  • CVE-2026-44687: Off-by-one error in harden-below-nxdomain logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN (bsc#1271893).
  • CVE-2026-44690: Cross-zone wildcard cache poisoning via RRSIG.labels manipulation (bsc#1271877).
  • CVE-2026-46582: Replay of a wildcard rrset as another piece of data triggers poisoning in the server expired reply path (bsc#1271894).
  • CVE-2026-50045: max-global-quota bypass via single client queries for a deeply nested name under a DNSSEC-signed parent (bsc#1271878).
  • CVE-2026-50046: Possible heap use-after-free in an error path when a DoT forwarded query is jostled out (bsc#1271882).
  • CVE-2026-50243: response-ip/rpz can rewrite BOGUS answers instead of returning SERVFAIL (bsc#1271880).
  • CVE-2026-50248: BOGUS configured primary hostname accepted for XFR in auth/rpz zones (bsc#1271881).
  • CVE-2026-50251: Attacker supplied 0.0.0.0/:: glue triggers defensive full-cache flush (bsc#1271883).
  • CVE-2026-50252: Possible cache poisoning attack by mapping source port population per thread (bsc#1271884).
  • CVE-2026-54478: DNS Cookie bypass when proxy-protocol with with answer-cookie:yes is used (bsc#1271895).
  • CVE-2026-55708: Privacy/configuration issue when adding local data in views through unbound-control (bsc#1271896).
  • CVE-2026-55717: serve-expired-client-timeout and response-ip CNAME redirect could lead to a crash (bsc#1271886).
  • CVE-2026-55973: DoS due to stack overflow triggered crash when dns-error-reporting: yes is set (bsc#1271874).
  • CVE-2026-55990: Crash via crafted client UDP query due to DNSCrypt faulty configuration (bsc#1271887).
  • CVE-2026-55991: Remote DNS-over-QUIC (DoQ) flow-control reacheable assertion failure in libngtcp2 (bsc#1271888).
  • CVE-2026-56416: Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name (bsc#1271889).
  • CVE-2026-56444: Degradation of resolution service when discard-timeout and serve-expired-client-timeout are combined in unusual configuration (bsc#1271890).

Other updates and bugfixes:

  • Version 1.25.2:
    • Features:
      • TTL behavior changes: cached records reaching TTL 0 are expired; TTL 0 upstream answers are no longer cached by cachedb; serve-expired-reply-ttl is now capped by the original TTL value; TTL decoding updated to adhere to RFC 8767 section 4
      • Add new statistics: num.queries.replyaddr_limit and requestlist.current.replies
      • Add 'log-thread-id' configuration option to log the system-wide Linux thread ID for easier debugging
      • Add ECC-GOST12 support per RFC 9558 (available as contrib/gost12.patch)
      • Allow synthesized DNAME TTL=0 to be served from cache within a 1-second grace period, reducing recursion for TTL=0 DNAMEs (RFC 2308)
      • Fix DoT/DoH/DoQ to reload certificates on config reload without requiring a full restart; fast_reload now supports changes to tls-service-key, tls-service-pem and tls-cert-bundle
      • Allow ip@port notation in control-interface configuration
      • Add iter-scrub-rrsig option (default: 8) to limit the number of …
Record
openSUSE-SU-2026:21550-1
Updated
2026-11-02
OSVROOT-OS-DEBIAN-11-CVE-2026-44690 No score

CVE-2026-44690 in unbound - Patched by Root

Root has patched CVE-2026-44690 in the unbound package for Root:Debian:11. Multiple fixed versions available.

Record
ROOT-OS-DEBIAN-11-CVE-2026-44690
Updated
2026-11-02
OSVROOT-OS-DEBIAN-12-CVE-2026-44690 No score

CVE-2026-44690 in unbound - Patched by Root

Root has patched CVE-2026-44690 in the unbound package for Root:Debian:12. Multiple fixed versions available.

Record
ROOT-OS-DEBIAN-12-CVE-2026-44690
Updated
2026-11-02
OSVROOT-OS-DEBIAN-13-CVE-2026-44690 No score

CVE-2026-44690 in unbound - Patched by Root

Root has patched CVE-2026-44690 in the unbound package for Root:Debian:13. Multiple fixed versions available.

Record
ROOT-OS-DEBIAN-13-CVE-2026-44690
Updated
2026-11-02
OSVSUSE-SU-2026:23050-1 No score

Security update for unbound

This update for unbound fixes the following issues:

Update to version 1.25.2.

Security issues fixed:

  • CVE-2026-14586: DoS via assertion in libngtcp2 for DNS-over-QUIC environments with high concurrency (bsc#1271879).
  • CVE-2026-32665: Remote DNS-over-QUIC denial of service due to quic-size budget bypass (bsc#1271873).
  • CVE-2026-40691: DoS due to heap overflow via single bad DNSCrypt query over TCP (bsc#1271875).
  • CVE-2026-41637: Degradation of resolution service due to improperly accounted client-terminated DNS-over-QUIC queries (bsc#1271891).
  • CVE-2026-42955: Ghost domain window can be extended by up to one cached TTL configured value for A/AAAA glue records (bsc#1271892).
  • CVE-2026-44621: Libunbound applications configured with unwanted-reply-threshold could eventually be abruptly terminated (bsc#1271876).
  • CVE-2026-44687: Off-by-one error in harden-below-nxdomain logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN (bsc#1271893).
  • CVE-2026-44690: Cross-zone wildcard cache poisoning via RRSIG.labels manipulation (bsc#1271877).
  • CVE-2026-46582: Replay of a wildcard rrset as another piece of data triggers poisoning in the server expired reply path (bsc#1271894).
  • CVE-2026-50045: max-global-quota bypass via single client queries for a deeply nested name under a DNSSEC-signed parent (bsc#1271878).
  • CVE-2026-50046: Possible heap use-after-free in an error path when a DoT forwarded query is jostled out (bsc#1271882).
  • CVE-2026-50243: response-ip/rpz can rewrite BOGUS answers instead of returning SERVFAIL (bsc#1271880).
  • CVE-2026-50248: BOGUS configured primary hostname accepted for XFR in auth/rpz zones (bsc#1271881).
  • CVE-2026-50251: Attacker supplied 0.0.0.0/:: glue triggers defensive full-cache flush (bsc#1271883).
  • CVE-2026-50252: Possible cache poisoning attack by mapping source port population per thread (bsc#1271884).
  • CVE-2026-54478: DNS Cookie bypass when proxy-protocol with with answer-cookie:yes is used (bsc#1271895).
  • CVE-2026-55708: Privacy/configuration issue when adding local data in views through unbound-control (bsc#1271896).
  • CVE-2026-55717: serve-expired-client-timeout and response-ip CNAME redirect could lead to a crash (bsc#1271886).
  • CVE-2026-55973: DoS due to stack overflow triggered crash when dns-error-reporting: yes is set (bsc#1271874).
  • CVE-2026-55990: Crash via crafted client UDP query due to DNSCrypt faulty configuration (bsc#1271887).
  • CVE-2026-55991: Remote DNS-over-QUIC (DoQ) flow-control reacheable assertion failure in libngtcp2 (bsc#1271888).
  • CVE-2026-56416: Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name (bsc#1271889).
  • CVE-2026-56444: Degradation of resolution service when discard-timeout and serve-expired-client-timeout are combined in unusual configuration (bsc#1271890).

Other updates and bugfixes:

  • Version 1.25.2:
    • Features:
      • TTL behavior changes: cached records reaching TTL 0 are expired; TTL 0 upstream answers are no longer cached by cachedb; serve-expired-reply-ttl is now capped by the original TTL value; TTL decoding updated to adhere to RFC 8767 section 4
      • Add new statistics: num.queries.replyaddr_limit and requestlist.current.replies
      • Add 'log-thread-id' configuration option to log the system-wide Linux thread ID for easier debugging
      • Add ECC-GOST12 support per RFC 9558 (available as contrib/gost12.patch)
      • Allow synthesized DNAME TTL=0 to be served from cache within a 1-second grace period, reducing recursion for TTL=0 DNAMEs (RFC 2308)
      • Fix DoT/DoH/DoQ to reload certificates on config reload without requiring a full restart; fast_reload now supports changes to tls-service-key, tls-service-pem and tls-cert-bundle
      • Allow ip@port notation in control-interface configuration
      • Add iter-scrub-rrsig option (default: 8) to limit the number of …
Record
SUSE-SU-2026:23050-1
Updated
2026-11-02
OSVSUSE-SU-2026:23215-1 No score

Security update for unbound

This update for unbound fixes the following issues:

Update to version 1.25.2.

Security issues fixed:

  • CVE-2026-14586: DoS via assertion in libngtcp2 for DNS-over-QUIC environments with high concurrency (bsc#1271879).
  • CVE-2026-32665: Remote DNS-over-QUIC denial of service due to quic-size budget bypass (bsc#1271873).
  • CVE-2026-40691: DoS due to heap overflow via single bad DNSCrypt query over TCP (bsc#1271875).
  • CVE-2026-41637: Degradation of resolution service due to improperly accounted client-terminated DNS-over-QUIC queries (bsc#1271891).
  • CVE-2026-42955: Ghost domain window can be extended by up to one cached TTL configured value for A/AAAA glue records (bsc#1271892).
  • CVE-2026-44621: Libunbound applications configured with unwanted-reply-threshold could eventually be abruptly terminated (bsc#1271876).
  • CVE-2026-44687: Off-by-one error in harden-below-nxdomain logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN (bsc#1271893).
  • CVE-2026-44690: Cross-zone wildcard cache poisoning via RRSIG.labels manipulation (bsc#1271877).
  • CVE-2026-46582: Replay of a wildcard rrset as another piece of data triggers poisoning in the server expired reply path (bsc#1271894).
  • CVE-2026-50045: max-global-quota bypass via single client queries for a deeply nested name under a DNSSEC-signed parent (bsc#1271878).
  • CVE-2026-50046: Possible heap use-after-free in an error path when a DoT forwarded query is jostled out (bsc#1271882).
  • CVE-2026-50243: response-ip/rpz can rewrite BOGUS answers instead of returning SERVFAIL (bsc#1271880).
  • CVE-2026-50248: BOGUS configured primary hostname accepted for XFR in auth/rpz zones (bsc#1271881).
  • CVE-2026-50251: Attacker supplied 0.0.0.0/:: glue triggers defensive full-cache flush (bsc#1271883).
  • CVE-2026-50252: Possible cache poisoning attack by mapping source port population per thread (bsc#1271884).
  • CVE-2026-54478: DNS Cookie bypass when proxy-protocol with with answer-cookie:yes is used (bsc#1271895).
  • CVE-2026-55708: Privacy/configuration issue when adding local data in views through unbound-control (bsc#1271896).
  • CVE-2026-55717: serve-expired-client-timeout and response-ip CNAME redirect could lead to a crash (bsc#1271886).
  • CVE-2026-55973: DoS due to stack overflow triggered crash when dns-error-reporting: yes is set (bsc#1271874).
  • CVE-2026-55990: Crash via crafted client UDP query due to DNSCrypt faulty configuration (bsc#1271887).
  • CVE-2026-55991: Remote DNS-over-QUIC (DoQ) flow-control reacheable assertion failure in libngtcp2 (bsc#1271888).
  • CVE-2026-56416: Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name (bsc#1271889).
  • CVE-2026-56444: Degradation of resolution service when discard-timeout and serve-expired-client-timeout are combined in unusual configuration (bsc#1271890).

Other updates and bugfixes:

  • Version 1.25.2:
    • Features:
      • TTL behavior changes: cached records reaching TTL 0 are expired; TTL 0 upstream answers are no longer cached by cachedb; serve-expired-reply-ttl is now capped by the original TTL value; TTL decoding updated to adhere to RFC 8767 section 4
      • Add new statistics: num.queries.replyaddr_limit and requestlist.current.replies
      • Add 'log-thread-id' configuration option to log the system-wide Linux thread ID for easier debugging
      • Add ECC-GOST12 support per RFC 9558 (available as contrib/gost12.patch)
      • Allow synthesized DNAME TTL=0 to be served from cache within a 1-second grace period, reducing recursion for TTL=0 DNAMEs (RFC 2308)
      • Fix DoT/DoH/DoQ to reload certificates on config reload without requiring a full restart; fast_reload now supports changes to tls-service-key, tls-service-pem and tls-cert-bundle
      • Allow ip@port notation in control-interface configuration
      • Add iter-scrub-rrsig option (default: 8) to limit the number of …
Record
SUSE-SU-2026:23215-1
Updated
2026-11-02
OSVSUSE-SU-2026:23226-1 No score

Security update for unbound

This update for unbound fixes the following issues:

Update to version 1.25.2.

Security issues fixed:

  • CVE-2026-14586: DoS via assertion in libngtcp2 for DNS-over-QUIC environments with high concurrency (bsc#1271879).
  • CVE-2026-32665: Remote DNS-over-QUIC denial of service due to quic-size budget bypass (bsc#1271873).
  • CVE-2026-40691: DoS due to heap overflow via single bad DNSCrypt query over TCP (bsc#1271875).
  • CVE-2026-41637: Degradation of resolution service due to improperly accounted client-terminated DNS-over-QUIC queries (bsc#1271891).
  • CVE-2026-42955: Ghost domain window can be extended by up to one cached TTL configured value for A/AAAA glue records (bsc#1271892).
  • CVE-2026-44621: Libunbound applications configured with unwanted-reply-threshold could eventually be abruptly terminated (bsc#1271876).
  • CVE-2026-44687: Off-by-one error in harden-below-nxdomain logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN (bsc#1271893).
  • CVE-2026-44690: Cross-zone wildcard cache poisoning via RRSIG.labels manipulation (bsc#1271877).
  • CVE-2026-46582: Replay of a wildcard rrset as another piece of data triggers poisoning in the server expired reply path (bsc#1271894).
  • CVE-2026-50045: max-global-quota bypass via single client queries for a deeply nested name under a DNSSEC-signed parent (bsc#1271878).
  • CVE-2026-50046: Possible heap use-after-free in an error path when a DoT forwarded query is jostled out (bsc#1271882).
  • CVE-2026-50243: response-ip/rpz can rewrite BOGUS answers instead of returning SERVFAIL (bsc#1271880).
  • CVE-2026-50248: BOGUS configured primary hostname accepted for XFR in auth/rpz zones (bsc#1271881).
  • CVE-2026-50251: Attacker supplied 0.0.0.0/:: glue triggers defensive full-cache flush (bsc#1271883).
  • CVE-2026-50252: Possible cache poisoning attack by mapping source port population per thread (bsc#1271884).
  • CVE-2026-54478: DNS Cookie bypass when proxy-protocol with with answer-cookie:yes is used (bsc#1271895).
  • CVE-2026-55708: Privacy/configuration issue when adding local data in views through unbound-control (bsc#1271896).
  • CVE-2026-55717: serve-expired-client-timeout and response-ip CNAME redirect could lead to a crash (bsc#1271886).
  • CVE-2026-55973: DoS due to stack overflow triggered crash when dns-error-reporting: yes is set (bsc#1271874).
  • CVE-2026-55990: Crash via crafted client UDP query due to DNSCrypt faulty configuration (bsc#1271887).
  • CVE-2026-55991: Remote DNS-over-QUIC (DoQ) flow-control reacheable assertion failure in libngtcp2 (bsc#1271888).
  • CVE-2026-56416: Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name (bsc#1271889).
  • CVE-2026-56444: Degradation of resolution service when discard-timeout and serve-expired-client-timeout are combined in unusual configuration (bsc#1271890).

Other updates and bugfixes:

  • Version 1.25.2:
    • Features:
      • TTL behavior changes: cached records reaching TTL 0 are expired; TTL 0 upstream answers are no longer cached by cachedb; serve-expired-reply-ttl is now capped by the original TTL value; TTL decoding updated to adhere to RFC 8767 section 4
      • Add new statistics: num.queries.replyaddr_limit and requestlist.current.replies
      • Add 'log-thread-id' configuration option to log the system-wide Linux thread ID for easier debugging
      • Add ECC-GOST12 support per RFC 9558 (available as contrib/gost12.patch)
      • Allow synthesized DNAME TTL=0 to be served from cache within a 1-second grace period, reducing recursion for TTL=0 DNAMEs (RFC 2308)
      • Fix DoT/DoH/DoQ to reload certificates on config reload without requiring a full restart; fast_reload now supports changes to tls-service-key, tls-service-pem and tls-cert-bundle
      • Allow ip@port notation in control-interface configuration
      • Add iter-scrub-rrsig option (default: 8) to limit the number of …
Record
SUSE-SU-2026:23226-1
Updated
2026-11-02
OSVSUSE-SU-2026:23349-1 No score

Security update for unbound

This update for unbound fixes the following issues:

Update to version 1.25.2.

Security issues fixed:

  • CVE-2026-14586: DoS via assertion in libngtcp2 for DNS-over-QUIC environments with high concurrency (bsc#1271879).
  • CVE-2026-32665: Remote DNS-over-QUIC denial of service due to quic-size budget bypass (bsc#1271873).
  • CVE-2026-40691: DoS due to heap overflow via single bad DNSCrypt query over TCP (bsc#1271875).
  • CVE-2026-41637: Degradation of resolution service due to improperly accounted client-terminated DNS-over-QUIC queries (bsc#1271891).
  • CVE-2026-42955: Ghost domain window can be extended by up to one cached TTL configured value for A/AAAA glue records (bsc#1271892).
  • CVE-2026-44621: Libunbound applications configured with unwanted-reply-threshold could eventually be abruptly terminated (bsc#1271876).
  • CVE-2026-44687: Off-by-one error in harden-below-nxdomain logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN (bsc#1271893).
  • CVE-2026-44690: Cross-zone wildcard cache poisoning via RRSIG.labels manipulation (bsc#1271877).
  • CVE-2026-46582: Replay of a wildcard rrset as another piece of data triggers poisoning in the server expired reply path (bsc#1271894).
  • CVE-2026-50045: max-global-quota bypass via single client queries for a deeply nested name under a DNSSEC-signed parent (bsc#1271878).
  • CVE-2026-50046: Possible heap use-after-free in an error path when a DoT forwarded query is jostled out (bsc#1271882).
  • CVE-2026-50243: response-ip/rpz can rewrite BOGUS answers instead of returning SERVFAIL (bsc#1271880).
  • CVE-2026-50248: BOGUS configured primary hostname accepted for XFR in auth/rpz zones (bsc#1271881).
  • CVE-2026-50251: Attacker supplied 0.0.0.0/:: glue triggers defensive full-cache flush (bsc#1271883).
  • CVE-2026-50252: Possible cache poisoning attack by mapping source port population per thread (bsc#1271884).
  • CVE-2026-54478: DNS Cookie bypass when proxy-protocol with with answer-cookie:yes is used (bsc#1271895).
  • CVE-2026-55708: Privacy/configuration issue when adding local data in views through unbound-control (bsc#1271896).
  • CVE-2026-55717: serve-expired-client-timeout and response-ip CNAME redirect could lead to a crash (bsc#1271886).
  • CVE-2026-55990: Crash via crafted client UDP query due to DNSCrypt faulty configuration (bsc#1271887).
  • CVE-2026-55991: Remote DNS-over-QUIC (DoQ) flow-control reacheable assertion failure in libngtcp2 (bsc#1271888).
  • CVE-2026-56416: Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name (bsc#1271889).
  • CVE-2026-56444: Degradation of resolution service when discard-timeout and serve-expired-client-timeout are combined in unusual configuration (bsc#1271890).

Other updates and bugfixes:

Record
SUSE-SU-2026:23349-1
Updated
2026-11-02
OSVSUSE-SU-2026:23360-1 No score

Security update for unbound

This update for unbound fixes the following issues:

Update to version 1.25.2.

Security issues fixed:

  • CVE-2026-14586: DoS via assertion in libngtcp2 for DNS-over-QUIC environments with high concurrency (bsc#1271879).
  • CVE-2026-32665: Remote DNS-over-QUIC denial of service due to quic-size budget bypass (bsc#1271873).
  • CVE-2026-40691: DoS due to heap overflow via single bad DNSCrypt query over TCP (bsc#1271875).
  • CVE-2026-41637: Degradation of resolution service due to improperly accounted client-terminated DNS-over-QUIC queries (bsc#1271891).
  • CVE-2026-42955: Ghost domain window can be extended by up to one cached TTL configured value for A/AAAA glue records (bsc#1271892).
  • CVE-2026-44621: Libunbound applications configured with unwanted-reply-threshold could eventually be abruptly terminated (bsc#1271876).
  • CVE-2026-44687: Off-by-one error in harden-below-nxdomain logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN (bsc#1271893).
  • CVE-2026-44690: Cross-zone wildcard cache poisoning via RRSIG.labels manipulation (bsc#1271877).
  • CVE-2026-46582: Replay of a wildcard rrset as another piece of data triggers poisoning in the server expired reply path (bsc#1271894).
  • CVE-2026-50045: max-global-quota bypass via single client queries for a deeply nested name under a DNSSEC-signed parent (bsc#1271878).
  • CVE-2026-50046: Possible heap use-after-free in an error path when a DoT forwarded query is jostled out (bsc#1271882).
  • CVE-2026-50243: response-ip/rpz can rewrite BOGUS answers instead of returning SERVFAIL (bsc#1271880).
  • CVE-2026-50248: BOGUS configured primary hostname accepted for XFR in auth/rpz zones (bsc#1271881).
  • CVE-2026-50251: Attacker supplied 0.0.0.0/:: glue triggers defensive full-cache flush (bsc#1271883).
  • CVE-2026-50252: Possible cache poisoning attack by mapping source port population per thread (bsc#1271884).
  • CVE-2026-54478: DNS Cookie bypass when proxy-protocol with with answer-cookie:yes is used (bsc#1271895).
  • CVE-2026-55708: Privacy/configuration issue when adding local data in views through unbound-control (bsc#1271896).
  • CVE-2026-55717: serve-expired-client-timeout and response-ip CNAME redirect could lead to a crash (bsc#1271886).
  • CVE-2026-55990: Crash via crafted client UDP query due to DNSCrypt faulty configuration (bsc#1271887).
  • CVE-2026-55991: Remote DNS-over-QUIC (DoQ) flow-control reacheable assertion failure in libngtcp2 (bsc#1271888).
  • CVE-2026-56416: Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name (bsc#1271889).
  • CVE-2026-56444: Degradation of resolution service when discard-timeout and serve-expired-client-timeout are combined in unusual configuration (bsc#1271890).

Other updates and bugfixes:

Record
SUSE-SU-2026:23360-1
Updated
2026-11-02
OSVSUSE-SU-2026:3884-1 No score

Security update for unbound

This update for unbound fixes the following issues:

Update to version 1.25.2.

Security issues fixed:

  • CVE-2026-40691: DoS due to heap overflow via single bad DNSCrypt query over TCP (bsc#1271875).
  • CVE-2026-42955: Ghost domain window can be extended by up to one cached TTL configured value for A/AAAA glue records (bsc#1271892).
  • CVE-2026-44621: Libunbound applications configured with unwanted-reply-threshold could eventually be abruptly terminated (bsc#1271876).
  • CVE-2026-44687: Off-by-one error in harden-below-nxdomain logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN (bsc#1271893).
  • CVE-2026-44690: Cross-zone wildcard cache poisoning via RRSIG.labels manipulation (bsc#1271877).
  • CVE-2026-46582: Replay of a wildcard rrset as another piece of data triggers poisoning in the server expired reply path (bsc#1271894).
  • CVE-2026-50046: Possible heap use-after-free in an error path when a DoT forwarded query is jostled out (bsc#1271882).
  • CVE-2026-50243: response-ip/rpz can rewrite BOGUS answers instead of returning SERVFAIL (bsc#1271880).
  • CVE-2026-50248: BOGUS configured primary hostname accepted for XFR in auth/rpz zones (bsc#1271881).
  • CVE-2026-50251: Attacker supplied 0.0.0.0/:: glue triggers defensive full-cache flush (bsc#1271883).
  • CVE-2026-50252: Possible cache poisoning attack by mapping source port population per thread (bsc#1271884).
  • CVE-2026-54478: DNS Cookie bypass when proxy-protocol with with answer-cookie:yes is used (bsc#1271895).
  • CVE-2026-55708: Privacy/configuration issue when adding local data in views through unbound-control (bsc#1271896).
  • CVE-2026-55717: serve-expired-client-timeout and response-ip CNAME redirect could lead to a crash (bsc#1271886).
  • CVE-2026-55990: Crash via crafted client UDP query due to DNSCrypt faulty configuration (bsc#1271887).
  • CVE-2026-56416: Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name (bsc#1271889).
  • CVE-2026-56444: Degradation of resolution service when discard-timeout and serve-expired-client-timeout are combined in unusual configuration (bsc#1271890).

Other updates and bugfixes:

Record
SUSE-SU-2026:3884-1
Updated
2026-11-02
OSVSUSE-SU-2026:3885-1 No score

Security update for unbound

This update for unbound fixes the following issues:

Update to version 1.25.2.

Security issues fixed:

  • CVE-2026-40691: DoS due to heap overflow via single bad DNSCrypt query over TCP (bsc#1271875).
  • CVE-2026-42955: Ghost domain window can be extended by up to one cached TTL configured value for A/AAAA glue records (bsc#1271892).
  • CVE-2026-44621: Libunbound applications configured with unwanted-reply-threshold could eventually be abruptly terminated (bsc#1271876).
  • CVE-2026-44687: Off-by-one error in harden-below-nxdomain logic can shadow a stub/forward zone by a legitimate parent's NXDOMAIN (bsc#1271893).
  • CVE-2026-44690: Cross-zone wildcard cache poisoning via RRSIG.labels manipulation (bsc#1271877).
  • CVE-2026-46582: Replay of a wildcard rrset as another piece of data triggers poisoning in the server expired reply path (bsc#1271894).
  • CVE-2026-50046: Possible heap use-after-free in an error path when a DoT forwarded query is jostled out (bsc#1271882).
  • CVE-2026-50243: response-ip/rpz can rewrite BOGUS answers instead of returning SERVFAIL (bsc#1271880).
  • CVE-2026-50248: BOGUS configured primary hostname accepted for XFR in auth/rpz zones (bsc#1271881).
  • CVE-2026-50251: Attacker supplied 0.0.0.0/:: glue triggers defensive full-cache flush (bsc#1271883).
  • CVE-2026-50252: Possible cache poisoning attack by mapping source port population per thread (bsc#1271884).
  • CVE-2026-54478: DNS Cookie bypass when proxy-protocol with with answer-cookie:yes is used (bsc#1271895).
  • CVE-2026-55708: Privacy/configuration issue when adding local data in views through unbound-control (bsc#1271896).
  • CVE-2026-55717: serve-expired-client-timeout and response-ip CNAME redirect could lead to a crash (bsc#1271886).
  • CVE-2026-55990: Crash via crafted client UDP query due to DNSCrypt faulty configuration (bsc#1271887).
  • CVE-2026-56416: Possible heap buffer overflow when validator canonicalizes RDATA that contains domain name (bsc#1271889).
  • CVE-2026-56444: Degradation of resolution service when discard-timeout and serve-expired-client-timeout are combined in unusual configuration (bsc#1271890).

Other updates and bugfixes:

Record
SUSE-SU-2026:3885-1
Updated
2026-11-02
OSVUSN-8946-1 No score

unbound vulnerabilities

It was discovered that Unbound incorrectly handled certain TCP connections. A remote attacker could possibly use this issue to cause Unbound to consume resources, leading to a denial of service. This issue only affected Ubuntu 26.04 LTS, Ubuntu 24.04 LTS, Ubuntu 22.04 LTS and Ubuntu 20.04 LTS. (CVE-2026-80225)

It was discovered that Unbound incorrectly handled certain DNS responses. A remote attacker could possibly use this issue to crash Unbound, resulting in a denial of service. (CVE-2026-81634)

It was discovered that Unbound incorrectly handled certain DNS responses during DNSSEC validation. A remote attacker could possibly use this issue to cause Unbound to consume resources, leading to a denial of service. (CVE-2026-85501)

It was discovered that Unbound incorrectly handled outgoing network ports. A remote attacker could possibly use this issue to crash Unbound, resulting in a denial of service. (CVE-2026-50252)

It was discovered that Unbound incorrectly handled certain DNSCrypt packets. A remote attacker could possibly use this issue to crash Unbound, resulting in a denial of service. This issue only affected Ubuntu 26.04 LTS, Ubuntu 24.04 LTS, Ubuntu 22.04 LTS, Ubuntu 20.04 LTS and Ubuntu 18.04 LTS. (CVE-2026-40691)

It was discovered that Unbound incorrectly handled certain cached DNS responses. A remote attacker could possibly use this issue to poison Unbound's cache. This issue only affected Ubuntu 26.04 LTS, Ubuntu 24.04 LTS, Ubuntu 22.04 LTS and Ubuntu 20.04 LTS. (CVE-2026-44690)

It was discovered that Unbound incorrectly handled certain DNS-over-QUIC connections. A remote attacker could possibly use this issue to cause Unbound to consume resources, leading to a denial of service. This issue only affected Ubuntu 26.04 LTS. (CVE-2026-32665)

It was discovered that Unbound incorrectly handled certain EDNS options. A remote attacker could possibly use this issue to crash Unbound, resulting in a denial of service. This issue only affected Ubuntu 26.04 LTS. (CVE-2026-55973)

Elias Heftrig, Haya Schulmann, Niklas Vogel, and Michael Waidner discovered that Unbound incorrectly handled validating DNSSEC messages. A remote attacker could possibly use this issue to cause Unbound to consume resources, leading to a denial of service. This issue only affected Ubuntu 18.04 LTS, Ubuntu 16.04 LTS and Ubuntu 14.04 LTS. (CVE-2023-50387)

It was discovered that Unbound incorrectly handled preparing an NSEC3 closest encloser proof. A remote attacker could possibly use this issue to cause Unbound to consume resources, leading to a denial of service. This issue only affected Ubuntu 18.04 LTS, Ubuntu 16.04 LTS and Ubuntu 14.04 LTS. (CVE-2023-50868)

Record
USN-8946-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
unbound
Alpine:v3.22
1.7.0 up to 1.25.2-r0
1.25.2-r0
unbound
Alpine:v3.23
1.7.0 up to 1.25.2-r0
1.25.2-r0
unbound
Alpine:v3.24
1.7.0 up to 1.25.2-r0
1.25.2-r0
python3-unbound
AlmaLinux:8
before 1.16.2-5.14.el8_10
1.16.2-5.14.el8_10
unbound
AlmaLinux:8
before 1.16.2-5.14.el8_10
1.16.2-5.14.el8_10
unbound-devel
AlmaLinux:8
before 1.16.2-5.14.el8_10
1.16.2-5.14.el8_10
unbound-libs
AlmaLinux:8
before 1.16.2-5.14.el8_10
1.16.2-5.14.el8_10
python3-unbound
AlmaLinux:9
before 1.24.2-3.el9_8.4
1.24.2-3.el9_8.4
unbound
AlmaLinux:9
before 1.24.2-3.el9_8.4
1.24.2-3.el9_8.4
unbound-devel
AlmaLinux:9
before 1.24.2-3.el9_8.4
1.24.2-3.el9_8.4
Show 104 moreShow less
Affected packages
PackageAffectedFixed
unbound-dracut
AlmaLinux:9
before 1.24.2-3.el9_8.4
1.24.2-3.el9_8.4
unbound-libs
AlmaLinux:9
before 1.24.2-3.el9_8.4
1.24.2-3.el9_8.4
python3-unbound
AlmaLinux:10
before 1.24.2-7.el10_2.4
1.24.2-7.el10_2.4
unbound
AlmaLinux:10
before 1.24.2-7.el10_2.4
1.24.2-7.el10_2.4
unbound-anchor
AlmaLinux:10
before 1.24.2-7.el10_2.4
1.24.2-7.el10_2.4
unbound-devel
AlmaLinux:10
before 1.24.2-7.el10_2.4
1.24.2-7.el10_2.4
unbound-dracut
AlmaLinux:10
before 1.24.2-7.el10_2.4
1.24.2-7.el10_2.4
unbound-libs
AlmaLinux:10
before 1.24.2-7.el10_2.4
1.24.2-7.el10_2.4
unbound-utils
AlmaLinux:10
before 1.24.2-7.el10_2.4
1.24.2-7.el10_2.4
unbound
Azure Linux:3
before 1.25.2-1
1.25.2-1
python3-unbound
TuxCare:AlmaLinux:9.6
before 1.16.2-19.el9_6.1.tuxcare.els11
1.16.2-19.el9_6.1.tuxcare.els11
unbound
TuxCare:AlmaLinux:9.6
before 1.16.2-19.el9_6.1.tuxcare.els11
1.16.2-19.el9_6.1.tuxcare.els11
unbound-devel
TuxCare:AlmaLinux:9.6
before 1.16.2-19.el9_6.1.tuxcare.els11
1.16.2-19.el9_6.1.tuxcare.els11
unbound-dracut
TuxCare:AlmaLinux:9.6
before 1.16.2-19.el9_6.1.tuxcare.els11
1.16.2-19.el9_6.1.tuxcare.els11
unbound-libs
TuxCare:AlmaLinux:9.6
before 1.16.2-19.el9_6.1.tuxcare.els11
1.16.2-19.el9_6.1.tuxcare.els11
unbound
Debian:12
All versions, plus listed versions
1.17.1-21.17.1-2+deb12u11.17.1-2+deb12u21.17.1-2+deb12u31.17.1-2+deb12u4
Show 22 moreShow less
1.17.1-2+loong641.18.0-11.18.0-21.19.1-11.19.2-11.20.0-11.21.1-11.22.0-11.22.0-21.23.1-11.24.0-11.24.0-21.24.1-11.24.1-21.24.2-11.25.0-11.25.1-11.25.2-11.26.0-11.26.0-21.26.1-11.26.2-1
None known
unbound
Debian:13
before 1.26.1-0+deb13u1, plus listed versions
1.22.0-21.22.0-2+deb13u11.22.0-2+deb13u21.22.0-2+deb13u31.23.1-1
Show 10 moreShow less
1.24.0-11.24.0-21.24.1-11.24.1-21.24.2-11.25.0-11.25.1-11.25.2-11.26.0-11.26.0-2
1.26.1-0+deb13u1
unbound
Debian:14
before 1.25.2-1, plus listed versions
1.22.0-21.23.1-11.24.0-11.24.0-21.24.1-1
Show 4 moreShow less
1.24.1-21.24.2-11.25.0-11.25.1-1
1.25.2-1
unbound
Mageia:10
before 1.25.2-1.mga10
1.25.2-1.mga10
unbound
Mageia:9
before 1.25.2-1.mga9
1.25.2-1.mga9
unbound
Mageia:10
before 1.26.1-1.mga10
1.26.1-1.mga10
unbound
Mageia:9
before 1.26.1-1.mga9
1.26.1-1.mga9
unbound
openEuler:22.03-LTS-SP4
before 1.13.2-25.oe2203sp4
1.13.2-25.oe2203sp4
unbound
openEuler:24.03-LTS-SP1
before 1.17.1-19.oe2403sp1
1.17.1-19.oe2403sp1
unbound
openEuler:24.03-LTS-SP3
before 1.17.1-19.oe2403sp3
1.17.1-19.oe2403sp3
unbound
openEuler:20.03-LTS-SP4
before 1.11.0-25.oe2003sp4
1.11.0-25.oe2003sp4
unbound
openEuler:24.03-LTS-SP4
before 1.17.1-20.oe2403sp4
1.17.1-20.oe2403sp4
python3-unbound
Red Hat:hummingbird:1
before 0:1.25.2-0.1.hum1
0:1.25.2-0.1.hum1
unbound
Red Hat:hummingbird:1
before 0:1.25.2-0.1.hum1
0:1.25.2-0.1.hum1
unbound-anchor
Red Hat:hummingbird:1
before 0:1.25.2-0.1.hum1
0:1.25.2-0.1.hum1
unbound-devel
Red Hat:hummingbird:1
before 0:1.25.2-0.1.hum1
0:1.25.2-0.1.hum1
unbound-dracut
Red Hat:hummingbird:1
before 0:1.25.2-0.1.hum1
0:1.25.2-0.1.hum1
unbound-libs
Red Hat:hummingbird:1
before 0:1.25.2-0.1.hum1
0:1.25.2-0.1.hum1
unbound-munin
Red Hat:hummingbird:1
before 0:1.25.2-0.1.hum1
0:1.25.2-0.1.hum1
unbound-utils
Red Hat:hummingbird:1
before 0:1.25.2-0.1.hum1
0:1.25.2-0.1.hum1
python3-unbound
Red Hat:enterprise_linux:8::appstream
before 0:1.16.2-5.14.el8_10
0:1.16.2-5.14.el8_10
python3-unbound-debuginfo
Red Hat:enterprise_linux:8::appstream
before 0:1.16.2-5.14.el8_10
0:1.16.2-5.14.el8_10
unbound
Red Hat:enterprise_linux:8::appstream
before 0:1.16.2-5.14.el8_10
0:1.16.2-5.14.el8_10
unbound-debuginfo
Red Hat:enterprise_linux:8::appstream
before 0:1.16.2-5.14.el8_10
0:1.16.2-5.14.el8_10
unbound-debugsource
Red Hat:enterprise_linux:8::appstream
before 0:1.16.2-5.14.el8_10
0:1.16.2-5.14.el8_10
unbound-devel
Red Hat:enterprise_linux:8::appstream
before 0:1.16.2-5.14.el8_10
0:1.16.2-5.14.el8_10
unbound-libs
Red Hat:enterprise_linux:8::appstream
before 0:1.16.2-5.14.el8_10
0:1.16.2-5.14.el8_10
unbound-libs-debuginfo
Red Hat:enterprise_linux:8::appstream
before 0:1.16.2-5.14.el8_10
0:1.16.2-5.14.el8_10
python3-unbound
Red Hat:enterprise_linux:9::appstream
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
python3-unbound-debuginfo
Red Hat:enterprise_linux:9::appstream
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
unbound
Red Hat:enterprise_linux:9::appstream
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
unbound-debuginfo
Red Hat:enterprise_linux:9::appstream
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
unbound-debugsource
Red Hat:enterprise_linux:9::appstream
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
unbound-dracut
Red Hat:enterprise_linux:9::appstream
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
unbound-libs
Red Hat:enterprise_linux:9::appstream
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
unbound-libs-debuginfo
Red Hat:enterprise_linux:9::appstream
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
python3-unbound-debuginfo
Red Hat:enterprise_linux:9::crb
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
unbound-debuginfo
Red Hat:enterprise_linux:9::crb
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
unbound-debugsource
Red Hat:enterprise_linux:9::crb
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
unbound-devel
Red Hat:enterprise_linux:9::crb
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
unbound-libs-debuginfo
Red Hat:enterprise_linux:9::crb
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
python3-unbound
Red Hat:enterprise_linux:10.2
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
python3-unbound-debuginfo
Red Hat:enterprise_linux:10.2
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
unbound
Red Hat:enterprise_linux:10.2
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
unbound-anchor
Red Hat:enterprise_linux:10.2
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
unbound-anchor-debuginfo
Red Hat:enterprise_linux:10.2
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
unbound-debuginfo
Red Hat:enterprise_linux:10.2
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
unbound-debugsource
Red Hat:enterprise_linux:10.2
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
unbound-dracut
Red Hat:enterprise_linux:10.2
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
unbound-libs
Red Hat:enterprise_linux:10.2
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
unbound-libs-debuginfo
Red Hat:enterprise_linux:10.2
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
unbound-utils
Red Hat:enterprise_linux:10.2
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
unbound-utils-debuginfo
Red Hat:enterprise_linux:10.2
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
unbound-devel
Red Hat:enterprise_linux:10.2
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
unbound
Rocky Linux:8
before 0:1.16.2-5.14.el8_10
0:1.16.2-5.14.el8_10
unbound
Rocky Linux:9
before 0:1.24.2-3.el9_8.4
0:1.24.2-3.el9_8.4
unbound
Rocky Linux:10
before 0:1.24.2-7.el10_2.4
0:1.24.2-7.el10_2.4
unbound
Root:Debian:11
before 1.13.1-1+deb11u7.aikido.3
1.13.1-1+deb11u7.aikido.31.13.1-1+deb11u7.aikido.41.13.1-1+deb11u7.aikido.51.13.1-1+deb11u7.aikido.6
rootio-unbound
Root:Debian:11
before 1.13.1-1+deb11u7.aikido.3
1.13.1-1+deb11u7.aikido.31.13.1-1+deb11u7.aikido.41.13.1-1+deb11u7.aikido.51.13.1-1+deb11u7.aikido.6
unbound
Root:Debian:12
before 1.17.1-2+deb12u4.aikido.2
1.17.1-2+deb12u4.aikido.21.17.1-2+deb12u4.aikido.31.17.1-2+deb12u4.aikido.41.17.1-2+deb12u4.aikido.5
rootio-unbound
Root:Debian:12
before 1.17.1-2+deb12u4.aikido.2
1.17.1-2+deb12u4.aikido.21.17.1-2+deb12u4.aikido.31.17.1-2+deb12u4.aikido.41.17.1-2+deb12u4.aikido.5
unbound
SUSE:Linux Micro 6.2
before 1.25.2-160000.1.1
1.25.2-160000.1.1
unbound
SUSE:Linux Enterprise Server 16.0
before 1.25.2-160000.1.1
1.25.2-160000.1.1
unbound
SUSE:Linux Enterprise Server for SAP applications 16.0
before 1.25.2-160000.1.1
1.25.2-160000.1.1
unbound
SUSE:Linux Micro 6.1
before 1.25.2-slfo.1.1_1.1
1.25.2-slfo.1.1_1.1
unbound
SUSE:Linux Micro 6.0
before 1.25.2-1.1
1.25.2-1.1
unbound
SUSE:Linux Enterprise Micro 5.5
before 1.25.2-150100.10.28.1
1.25.2-150100.10.28.1
unbound
SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
before 1.25.2-150100.10.28.1
1.25.2-150100.10.28.1
unbound
SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
before 1.25.2-150100.10.28.1
1.25.2-150100.10.28.1
unbound
SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
before 1.25.2-150100.10.28.1
1.25.2-150100.10.28.1
unbound
SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
before 1.25.2-150100.10.28.1
1.25.2-150100.10.28.1
unbound
SUSE:Linux Enterprise Server 15 SP4-LTSS
before 1.25.2-150100.10.28.1
1.25.2-150100.10.28.1
unbound
SUSE:Linux Enterprise Server 15 SP5-LTSS
before 1.25.2-150100.10.28.1
1.25.2-150100.10.28.1
unbound
SUSE:Linux Enterprise Server for SAP Applications 15 SP4
before 1.25.2-150100.10.28.1
1.25.2-150100.10.28.1
unbound
SUSE:Linux Enterprise Server for SAP Applications 15 SP5
before 1.25.2-150100.10.28.1
1.25.2-150100.10.28.1
unbound
SUSE:Linux Enterprise Module for Basesystem 15 SP7
before 1.25.2-150600.23.19.1
1.25.2-150600.23.19.1
unbound
SUSE:Linux Enterprise Module for Package Hub 15 SP7
before 1.25.2-150600.23.19.1
1.25.2-150600.23.19.1
unbound
SUSE:Linux Enterprise Server 15 SP6-LTSS
before 1.25.2-150600.23.19.1
1.25.2-150600.23.19.1
unbound
SUSE:Linux Enterprise Server for SAP Applications 15 SP6
before 1.25.2-150600.23.19.1
1.25.2-150600.23.19.1
unbound
Ubuntu:Pro:20.04:LTS
before 1.9.4-2ubuntu1.11+esm3, plus listed versions
1.9.0-2ubuntu11.9.0-2ubuntu21.9.4-21.9.4-2ubuntu11.9.4-2ubuntu1.1
Show 10 moreShow less
1.9.4-2ubuntu1.21.9.4-2ubuntu1.31.9.4-2ubuntu1.41.9.4-2ubuntu1.51.9.4-2ubuntu1.61.9.4-2ubuntu1.81.9.4-2ubuntu1.91.9.4-2ubuntu1.111.9.4-2ubuntu1.11+esm11.9.4-2ubuntu1.11+esm2
1.9.4-2ubuntu1.11+esm3
unbound
Ubuntu:22.04:LTS
before 1.13.1-1ubuntu5.17, plus listed versions
1.13.1-1ubuntu11.13.1-1ubuntu31.13.1-1ubuntu51.13.1-1ubuntu5.11.13.1-1ubuntu5.2
Show 12 moreShow less
1.13.1-1ubuntu5.31.13.1-1ubuntu5.41.13.1-1ubuntu5.51.13.1-1ubuntu5.71.13.1-1ubuntu5.81.13.1-1ubuntu5.101.13.1-1ubuntu5.111.13.1-1ubuntu5.121.13.1-1ubuntu5.131.13.1-1ubuntu5.141.13.1-1ubuntu5.151.13.1-1ubuntu5.16
1.13.1-1ubuntu5.17
unbound
Ubuntu:24.04:LTS
before 1.19.2-1ubuntu3.12, plus listed versions
1.17.1-21.18.0-2ubuntu11.18.0-2ubuntu21.19.1-1ubuntu11.19.2-1ubuntu1
Show 11 moreShow less
1.19.2-1ubuntu31.19.2-1ubuntu3.11.19.2-1ubuntu3.21.19.2-1ubuntu3.31.19.2-1ubuntu3.41.19.2-1ubuntu3.51.19.2-1ubuntu3.61.19.2-1ubuntu3.71.19.2-1ubuntu3.81.19.2-1ubuntu3.91.19.2-1ubuntu3.10
1.19.2-1ubuntu3.12
unbound
Ubuntu:26.10
All versions, plus listed versions
1.24.2-1ubuntu21.25.1-1ubuntu11.25.1-1ubuntu3
None known
unbound
Ubuntu:26.04:LTS
before 1.24.2-1ubuntu2.4, plus listed versions
1.22.0-2ubuntu21.22.0-2ubuntu41.24.2-1ubuntu11.24.2-1ubuntu21.24.2-1ubuntu2.11.24.2-1ubuntu2.21.24.2-1ubuntu2.3
1.24.2-1ubuntu2.4
unbound
Ubuntu:Pro:14.04:LTS
before 1.4.22-1ubuntu4.14.04.3+esm5, plus listed versions
1.4.20-11.4.21-11.4.21-1ubuntu11.4.21-1ubuntu21.4.22-1ubuntu1
Show 10 moreShow less
1.4.22-1ubuntu21.4.22-1ubuntu31.4.22-1ubuntu41.4.22-1ubuntu4.14.04.11.4.22-1ubuntu4.14.04.21.4.22-1ubuntu4.14.04.31.4.22-1ubuntu4.14.04.3+esm11.4.22-1ubuntu4.14.04.3+esm21.4.22-1ubuntu4.14.04.3+esm31.4.22-1ubuntu4.14.04.3+esm4
1.4.22-1ubuntu4.14.04.3+esm5
unbound
Ubuntu:Pro:16.04:LTS
before 1.5.8-1ubuntu1.1+esm5, plus listed versions
1.4.22-1ubuntu61.5.7-1ubuntu11.5.7-1ubuntu21.5.8-1ubuntu11.5.8-1ubuntu1.1
Show 4 moreShow less
1.5.8-1ubuntu1.1+esm11.5.8-1ubuntu1.1+esm21.5.8-1ubuntu1.1+esm31.5.8-1ubuntu1.1+esm4
1.5.8-1ubuntu1.1+esm5
unbound
Ubuntu:Pro:18.04:LTS
before 1.6.7-1ubuntu2.6+esm6, plus listed versions
1.6.5-11.6.7-11.6.7-1build11.6.7-1ubuntu11.6.7-1ubuntu2
Show 10 moreShow less
1.6.7-1ubuntu2.11.6.7-1ubuntu2.21.6.7-1ubuntu2.31.6.7-1ubuntu2.41.6.7-1ubuntu2.51.6.7-1ubuntu2.61.6.7-1ubuntu2.6+esm21.6.7-1ubuntu2.6+esm31.6.7-1ubuntu2.6+esm41.6.7-1ubuntu2.6+esm5
1.6.7-1ubuntu2.6+esm6
unbound
openSUSE:Tumbleweed
before 1.25.2-1.1
1.25.2-1.1
unbound
openSUSE:Leap 16.0
before 1.25.2-160000.1.1
1.25.2-160000.1.1

History

History
WhenChangedSources
2026-11-03affected
2026-11-02affected, aliases, published, referencesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 194 moreShow less
This page doesn't list everything

Left out here: 15 references and the rest of 10 source descriptions. The JSON record has them.

MoveEnter Open